TechSpot

0x00000050 Hang when connecting USB Device! Help!

By Telit
Jun 24, 2005
  1. Hello,

    I encountered a system hang when plugging in a Casio Exilim EX-Z750 camera (technically, when plugging the cradle+camera) to the computer.
    When plugging the device, the computer recognizes the 'Disk Drive' and the Casio Camera, but a few seconds later I get the STOP screen.

    Error message: STOP 0x00000050 (0xFFFFFFe8,0x00000001,0x804E1928,0x00000000)

    I haven't found anything substantial on this issue yet.
    I am running Windows XP Professional SP2 on an Intel Pentium 4 2.4Ghz, 512MB RAM. Also, I am running Norton Antivirus 2005.

    When testing the same device on an IBM T42 Thinkpad, with the same OS, the device worked seamlessly.

    I'll appreciate any help I can get.
     
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Do you have anything else hooked up to your USB ports? You might want to remove your USB devices from the device manager, and restart windows, and let it reinstall them.

    BTW
    :wave:Welcome to TechSpot:wave:
     
  3. Telit

    Telit TS Rookie Topic Starter

    Thanks for having me here. :)

    Anyway, there are NO other USB devices connected at the moment. The problem still persists.

    Oddly enough, the device manager lists:
    4 USB Host Contollers
    1 Standard Enhanced PCI to USB Host Controller
    5 USB Root Hubs

    Up until know, every USB device I plugged worked fine. Are there supposed to be so many devices on the list (pardon the ignorance)? I have two USB plugs on the anterior side of my case, and two on the back.

    I noticed the problem only occurs when using the back connections, and not when using the front ones. Any thought(s)?
     
  4. Telit

    Telit TS Rookie Topic Starter

    Oh, I also tried running Microsoft Driver Verifier, but windows wouldn't start and I had to rollback.
     
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Depending on your motherboard, the front and back USB ports could be different, i.e. back = USB1.1, front = USB2.0 or vice versa.
    Is that PC on a network with 'mapped' drives?
    If so, move the driveletter from those maps up a few letters (in other worde re-map), thus freeing letters right after HD/CD/DVD for the extra 'drive' that your camera is. USB does not 'see' mapped or virtual drives.
     
  6. Telit

    Telit TS Rookie Topic Starter

    I tried removing all the USB devices. Windows reinstalled the same devices again after booting up, but still, when connecting the device to the rear USB connections I get the 0x00000050 BSoD.

    I do have mapped network drives, but they're mapped to Z: and Y:
    Any thoughts?
     
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Have you tried any other USB port? Or are you sticking it in the same one each time? Possibly try the front ports.
     
  8. Telit

    Telit TS Rookie Topic Starter

    Well, as I noted before, when using the front ports the device works fine. Also, when using it on a different computer, like an IBM T42 Thinkpad.

    I'm still trying to crack the problem of the back ports.
     
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Check the wiring from rear-USB to mobo, if the wires were connected to a wrong pin, that could be the cause.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...