2 copies of XP after formatting

By xeriouxi
Nov 2, 2005
  1. Hi!

    I just completely formatted/reinstalled XP and when I start up there are 2 XP options to select, one saying there is a problem loading it. I thought formatting got rid of everything so why is there 2 options? I cleared all partitions and now have just one. I didnt use the RAID driver as someone said I didnt need it, and installation seemed to go fine showing it as one hard drive. Anyone explain this? ^^
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Did you erase all partitions during setup? Not just format but erase them all so there is just ONE line on the page to select your HDD.

    Back in setup, you have to select each entry and click "D" to delete, until there is just one line that is "unpartitioned space". Then select this one line and move on to the format options.
    Otherwise, just remove the bad entry from your boot.ini file on the root of the drive.
  3. xeriouxi

    xeriouxi TS Rookie Topic Starter

    Yeah I did. I got a Dell Dimension 9100 and it had some recovery partition and I cleared every partition then formatted the unpartitioned space. If I remember correctly I created a partition and then formatted is this wrong to do?
  4. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Personally, I would have deleted both partitions, created one large partition and formatted/installed XP. You shouldn't have this problem if you had done that, but who knows with Windows.... :)

    To remove the 2nd instance of XP, there's a few things you can do. Boot from the Windows XP installation CD. When the screen (see below) appears, choose recovery console. Type in bootcfg /rebuild and press enter. This should fix the problem.. just follow any prompts appropriately afterward.

    *I apologize for the arrow in the wrong place... it's from another post.

    You can find a complete explanation of the bootcfg command here:
  5. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    If there is just one "unpartitioned space" line in XP setup, there is no need to "create" a partition, XP will do that automatically. You just select the one line and move on. However I doubt that has to do with your problem.

    I may want to just chalk this up to XP odd behavior. Because this happens to me as well, off and on. Like just 2 days ago to be exact. I loaded an XP pro, one HDD, one partition, but then out of nowhere it adds another line under "Windows XP Professional" called "Windows Whistler Edition". So I just deleted the line from Boot.ini.

    Besides Rick's way of editing the file, there are two more.

    1) Is to just go in My Computer, turn on showing hidden/system files, find boot.ini, and delete the 2nd entry.

    2) Right-click My Computer, choose Properties. Click the Advanced Tab. Then the Settings button under "Start and Recovery". Then there is an "Edit" button towards the top that lets you edit the file.

    Other then that, don't worry about it, you really don't have "two" OSs loaded, or any wasted space. XP just mistakenly thought you had another installation.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...