TechSpot

5.1 just is'nt working right

By Sarcazmo
Sep 2, 2005
Topic Status:
Not open for further replies.
  1. Hi All..
    I Just became a member today so will be filling in spec's and stuff out later ,but for now i really am clueless on a sound prob i have...my pc has been good and never had much trouble,accept with 5.1 surround sound,i just upgraded to a catalina 7.1 sound card thinking it was the onboard sound card which was the problem and it is amazing on two channel audio n so on but when it comes to dvd's and anything in surround i come up with the same problem again it play's from all sound's but the subwoofer is hardly there nor is the center,i have to more or less shut off the front and rear speakers just to hear it..i have nTech 5.1 surround system and it is very frustrating as i have tried everything..i am just out of idea's why this is happening :( ...could anyone help me sort this problem out,pls?..

    Thanks
  2. zephead

    zephead TechSpot Paladin Posts: 2,483

    you need to follow your manual for proper setup for the desired surround sound array. this involves making settings on your computer, hooking things up right, and setting up your dvd audio.
  3. Sarcazmo

    Sarcazmo TS Rookie Topic Starter

    okies,ty will it a try
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.