500GB SATA Drive Problems

By Tramakan
May 21, 2007
Topic Status:
Not open for further replies.
  1. I'm running XP Pro and added a IBM Deskstar SATA 500GB hard drive. The drive is a bare drive that i put into an enclosure and use a SATA>USB connector. The drive ran fine with no problems. I then moved the drive to a Mac (OSX) to move files around (MP3's/Flac) and when plugging it back into the PC it won't recognize it in "My Computer". It shows up in device manager as mass storage but won't let me do anything with it. If i click on 'populate' it shows as unrecognized drive. If i move it back over to the Mac it seems to run fine. Now i'm just looking to get it working on the PC and not deal with it on the Mac. Is there any special way i can format it on the Mac to make the PC hopefully read it better?
  2. tipstir

    tipstir TS Ambassador Posts: 4,616   +82

    You might have to re-format it for NTFS as the MAC uses a different file system, something might have been put on and change the structure of the HDD to work with the MAC OS. You should move files over the network from WIN OS to MAC OS instead and it's safer to do it that way..
  3. Tramakan

    Tramakan Newcomer, in training Topic Starter

    Thanks for the quick reply. I'm now moving files via the network and plan to keep the hard drive just for the PC. Problem is that i can't get Windows to recognize it so i can re-format to NTFS.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.