TechSpot

6800 Ultra Extreme Edition extremely choppy with Direct3D

By Count Orlock
Dec 20, 2004
  1. This sounds like a driver issue but I don't know: Basically, the problem is that Direct3D based games (Half-Life 2/3DMark05) hang-up on my machine. It renders a few frames but then freezes for about 30 seconds...renders a few more frames...freezes 30 secs and so on. OpenGL (Doom 3), on the other hand, runs just fine. I've upgraded to the latest ForceWare driver (I even tried using the uncertified ForceWare 71.20 from guru3d). I've flashed my BIOS and upgraded my chipset driver all to no avail. Nothing on my system is overclocked...unless it's a factory overclock I don't know about. Is there any way a hardware glitch on my video card would produce Direct3D problems but not affect OpenGL?

    System specs:
    EVGA gForce 6800 Ultra Extreme Edition
    MSI K8N Neo2 (nForce 3 Ultra)
    Athlon 3500+
    1 gig of OCZ EL DDR PC-3200 Platinum Revision 2
    WD 740GD Raptor
    Turbo-Cool 425 Deluxe

    Any help/suggestions would be greatly appreciated.
     
  2. nogaard777

    nogaard777 TS Rookie

    I'm sure you've solved this problem by now but for anyone else that would happen upon this page, the problem is from lack of power. I run a 6800 Ultra that did exactly the same thing until I bought a new Ultra X-Connect 500w and all the issues magically dissappeared. Just an FYI.
     
  3. TempleDwarf

    TempleDwarf TS Rookie

    Getting a 450w supply with new computer...

    Ok, I will get a 450w supply for my computer, but I'm also going to get a geforce 6800 ultra. I understand that they recommend a 480w supply for this card...Will this be a problem?
     
  4. nogaard777

    nogaard777 TS Rookie

    If the power supply is of good quality not a 2 pound pricewatch special you should be OK.
     
  5. surfsand

    surfsand TS Rookie

    ok here is the fix. your card is probably over clocked. so you need to get a tweek program to turn down the settings.

    i used Riva Tuner. get it here
    http://downloads.guru3d.com/download.php?id=13

    after you install the program go to \main\driver settings(forceware detected)\customize\system settings

    bring the Core clock down to 400 and the memory clock down to 1100.

    i havent had a freeze up since.
    |
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.