A double dose of trouble (HELP). Firewall won't go on plus more

By talosian
Nov 25, 2005
  1. Two problems which I can't figure out though I have Googled both and done a lot of "research" on them.

    Working w/Windows XP

    1. I type a URL in the address bar and it takes 60+ seconds for the page to load.

    2. I can't turn on Windows Firewall. Yes, I have read the sintructions and followed them but it won't turn on.

    Have Norton AV (clean) and checked for spyware and seems OK.

    I seem to have a high drain on the CPU even with little or nothing running.

    Suggestions/Input appreciated.

  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    check event viewer
    do search here for spyware hijack
    do away with norton (junk)
    AV is free and does not suck up your cpu
    adaware is free hijackthis is free
    somethings in life are better free
  3. talosian

    talosian TS Rookie Topic Starter

    Thanks for the info. I'm not terribly computer savvy so possibly you could be more specific/detailed on what you think my problem is and how to get the programs you mentioned.

  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    He means, get rid of Norton/Symantec and install the free AVG antivirus from
    Then go to and get the free Sygate Personal firewall.

    And if you are on a network, in Explorer/Tools check if you can unmap/disconnect any networked drives. They hold up tremendously.
  5. talosian

    talosian TS Rookie Topic Starter

    Thanks RealBlackStuff

    I'll check this out. What struck me as interesting is that these problems happened w/o warning. My first throght was a virus or spyware.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...