TechSpot

A Video Card problem

By Ddep
Jan 8, 2009
  1. I recently received a factory-ordered Lenovo t500 laptop for christmas, running Vista Home Basic 32bit. It came specially with an ATI Mobility Radeon 3650 graphics card. For about my first week of gaming, the card ran fine, but it recently slowed drastically. When I checked various diagnostics, it showed that my computer was now running what it called 'Mobile Intel 4 series Express Chipset Family', and had gone from 256MB of processor power to 32. My computer gives no indication of even currently having the card installed, and only my recollections and the receipts from the order form show that it existed.
    Tech support hasn't been able to help because it's a factory-ordered computer.

    Help me, Techies of the Internet!
    I'm getting desperate!
     
  2. skitzo_zac

    skitzo_zac TechSpot Chancellor Posts: 418

    You can download and install the Video drivers for your laptop from Lenovo here.

    Download and install them, hopefully that will resolve your issue. Please report back on the outcome.
     
  3. Ddep

    Ddep TS Rookie Topic Starter

    I installed the drivers, which made the correct card show up in the device manager (it wasn't there previously) It still isn't working, however- the vice manger is telling me that it can't find the drivers, despite the fact that I've downloaded the latest Catalyst driver for it.

    --Edit--

    Never mind. I reenabled the less powerful driver and restarted my computer, noly to find that the powerful driver is working again.

    Skitzo-zac, I can't express in words how much your help means to me.
    Thank you from the bottom of my heart. I don't know what happened, but it worked!
     
  4. Ddep

    Ddep TS Rookie Topic Starter

    I'm sorry to resurrect an old thread, but I've been having problems again.

    My 3650 card has deactivated again (I believe it somehow results from having installed Age of Empires 3 the Warchiefs on my computer) I have to aforementioned graphics drivers installed, yet the card is still only showing up in the Device manager in Safe Mode.

    Help! Again!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...