About to install new hard drive, question about sata drivers

By fenix07
Feb 12, 2007
Topic Status:
Not open for further replies.
  1. I'm about to add a new sata hard drive to my pc, and I intend to clone the old IDE hard drive to the new one. From what I have read, it appears that Windows XP will not recognize a sata drive unless you have sata drivers installed. So here's my queston:

    I think I have located the drivers on my mobo driver cd, are the Promise SATA378 that I see on the cd the correct drivers that I need to put onto a floppy (there are also VIARAID drivers on the cd as well)? Also, it's version number is v1.00.0.26, are these the latest drivers?

    Oh yeah, my mobo is an ASUS P4P8X SE with an intel p4 3 ghz.

    Thanks for your help.
  2. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

  3. fenix07

    fenix07 Newcomer, in training Topic Starter

    I cannot find SATA drivers for my mobo on ASUS's website, it's like it doesn't exist. Now are promise drivers compatible with my mobo? I do see different drivers listed on promise's website, though I do not see the specific ones I have which is SATA378.

    Sorry, but can you elaborate on this (my mobo manual has no instructions for this step)?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,454   +135

    All you need to do is to go into the motherboards bios and enable the SATA controller and set the boot sequence to SATA from IDE
  5. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Any software you need can be found on the website of the hard drive manufacturer... apart from enabling the SATA controller on the motherboard... If you don't have those details, they are definitely available at the ASUS website for that motherboard model
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,454   +135

    Am I in another dimention here? I have built 10 SATA systems in the last 3 months, and I have never needed additional SATA drivers, except for the SATA/RAID, if I so enabled and built a SATA RAID configuration...

    FOR STANDARD SATA DRIVES UNDER XP, NO ADDITIONAL SATA DRIVERS ARE NEEDED... Is that clear enough?
  7. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    This is true, for the most part. There are some exceptions, but most SATA controllers that have an 'IDE emulation' (or simliar) feature will work without drivers.
  8. fenix07

    fenix07 Newcomer, in training Topic Starter

    Already installed new hard drive, but a few issues

    Okay, I finally installed my new hard drive, and have already cloned the old hard drive to the new one. I've changed the BIOS settings to instruct the computer to boot from the new hard drive. Everything apparently is fine, but sometimes my internet works, and sometimes it doesn't. In addition, I also get a message from Windows that it encountered a Win32 process error and cannot run, and it references the svchost.exe process. Does this have to with the fact that my new hard drive, and the svchost.exe, is referenced as and located in J:\?

    Also, the C:\ is still listed with the old hard drive, and now I would like the new hard drive to be called C:\. Does anyone know how do I do this? I have Norton PMagic 8.0 and Ghost 10.0 installed, but their manuals do not tell me how to do this. Thanks
  9. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    You cannot just copy your old Windows XP install to a new drive and expect it to work properly. Now you should use your Windows XP CD to "repair" the install on the new drive.
    You can re-establish drives by changing to one drive, then adding the second... jumpering them as master and slave, and/or going to Control Panel -> Administrative Tools -> Computer Management -> Storage -> Disk Management and changing the drive numbers there.
  10. fenix07

    fenix07 Newcomer, in training Topic Starter

    Raybay,

    I installed a Seagate SATA hard drive, so there's no need to mess around with master/slave settings. And I used Norton Ghost to clone the old hard drive. Doesn't Norton Ghost take care of the cloning operation (albeit, not so smoothly)?

    Also, tried going into Disk Management, and I tried to change the drive letters, but Windows says that it cannot modify the letters, but I think that's because I'm using Norton PMagic, so Windows Disk Management is locked out. So I'm still having these issues...
  11. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Is the drive letter of your new SATA drive C:? If you aren't sure, you can see what Windows thinks is the system path by clicking Start > Run > cmd /k echo %systemroot%

    If it is anything other than C:, you need to do the ghosting again. This time though, after you ghost your drive successfully. Shut the computer off, remove your IDE drive and let Windows boot alone on the SATA drive. Is it C: now? If so, connect your old drive and you should be OK.
  12. fenix07

    fenix07 Newcomer, in training Topic Starter

    Hi Rick, I did what you said. I ghosted my drive again and shut down the computer before it attempted to boot (Ghost would only allow me to run this operation in the Recovery Environment). However, when I booted to Windows, Windows will lock up at the Logon screen, in fact, the user accounts fail to load up. I also checked the BIOS settings, but it reads my Seagate hard drive, which is the new hd, as the third ide drive, but lists nothing for the primary master drive, and BIOS does not let me change these settings. And I also ensured that BIOS is configured to allow for SATA hds.

    So I'm at a complete loss as to how to fix this problem.

    UPDATE:

    Okay, I recopied my hard drive using the Seagate Discwizard, and my new hard drive now has the C:\ letter. However, this is only when I have my old hard drive, an IDE Western Digital, disconnected; when I reconnected it, then Windows detects the WD as the C:\ and the Seagate as the J:\. I remember that DiscWizard provided instructions about changing the jumper settings on the WD and the Seagate drive, but it did not entirely make sense since it said that I had to change the jumper settings of the Seagate drive, even though it's a SATA. Is it possible though that I do need to change the jumper settings on the WD drive to slave?

    Also, I'm having a little issue with MS Office 2003. I can open and print Word documents, but I get an error box titled "Microsoft Office Word 11.0" and the box says "An error occured and this feature is no longer functioning properly. Please run Setup and select 'Repair' to restore this application." I tried to reinstall Office but I get another error box that says "This patch package cannot be opened. Verify that the patch package exists and that you can access it, or contact the application vendor that this is a valid Windows Installer package." Now, although my copy of Office is a burned copy of the original, I already tried this cd on my laptop, which has MS Office 2003, and the cd works fine.

    I know this a lot of info that I posted, but your assistance is greatly appreciated. Thanks
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.