AC97 & legacy drivers

By tashun
Jul 13, 2009
  1. Can I disable AC'97 and install another audio driver?I don't have a reinstall disc.I alwys get BSOD when I activate sound,or if I don't get BSOD it slows my system down.What can I do for C-Media AC'97?I've been on C-Media already. What are Legacy audio? Because I have to installedon my computer,ALSO I have Window XP Professional.Thanks for any help!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Have you installed XP Service Pack 3? ...and all the other updates?
  3. tashun

    tashun TS Rookie Topic Starter Posts: 28

    Service Pack3

    No,I haven't installed SP3 yet.I read on a couple of forums that it wasn't good.So what is the purpose for SP3? I really don't know.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    You came here for help... We recommend that anyone running Windows download and install all Windows Updates, and Service Packs. Doing so might just fix your sound issues
  5. tashun

    tashun TS Rookie Topic Starter Posts: 28

    Yes I did come for help...I asked what does SP3 do,what's the difference? I'm asking a question,so I can have some insight on what its purpose is.I'm asking question hoping to gain some knowledge of the problem.So why do I need SP3?

    ( Hosea 4:6)My people are destroyed for lack of knowledge: because thou hast rejected knowledge, I will also reject thee, that thou shalt be no priest to me: seeing thou hast forgotten the law of thy God, I will also forget thy children...King James Bible
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183


    Take a look at this post to start: The value of installing XP SP3 vs. SP2 + updates

    There's much value in SP3...
  7. arkantos

    arkantos TS Member Posts: 46

    updating to SP3 may help fix your sound problems.
  8. tashun

    tashun TS Rookie Topic Starter Posts: 28

    SP3 Value

    LookAround,I thank you for directing me to an earlier post of yours.I have an older system though,and I read people personal experiences with SP3. But I will take your advice and install it. So will that possibly narrow down my audio/video problem? Because with audio I have no video,without audio I have video.Thanks
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    btw.. There are things to consider when reading other people's reviews/comments about SP3: when were their comments written? and "which SP3" were they commenting on?
    1. Many people installed pre-releases of SP3. Not surprisingly, those people were finding problems trying to use a version that was not yet officially released
    2. Of course, once SP3 was officially released, there were still some problems in some specific cases. But that official release was a year ago so all of those problems have also been fixed.
    Also see USB Device Problems? Check for Windows Updates. Altho it's about USB, it does also include some tips when upgrading from SP2 to SP3

    Of course, there's still no guarantee that this will fix your problem. Let us know how things look after the upgrade. And can take a look again if need be once we know you're running on an SP3 base
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Glad you came around to finally install XP SP3... There will be some more updates needed after you install SP3
  11. tashun

    tashun TS Rookie Topic Starter Posts: 28

    SP3 Install

    Hey guys...LookinAround and Tmagic650.I finally got a chance to install SP3 yesterday,my sound is activated.Haven't gotten BSOD yet hope not too,but I still can't watch videos on youtube in particular,I see a picture and hear sound.It buffers but no movement,also in my system there's a yellow circle with an exclamation on video controllers(VGA Comptible).I don't have a retore disc.Is there anything I can do and what is this for anyway? Thanx a ton guys for any help:D
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Have you downloaded any hardware updates shown in Windows Update? There should be more updates available after installing XP SP3
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    As Tmagic650, points out be sure you've installed all the Windows Updates (both critical and all hardware optional).
    1) When you run Windows Update click the Custom button and install all the critical and hardware optional updates it finds (software optional are at your choice)
    2) Also be sure to continue to keep running windows update until it finally answers "no more udpates"

    If your problem continues after doing the above let us know and we can check your drivers at that point
  14. tashun

    tashun TS Rookie Topic Starter Posts: 28


    Tmagic650 yes I've installed the available updates so far,still can't watch any video. LookinAround thanks for the tip,I'll do the custom install asap.I'll let you guys know my outcome.:wave:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...