Accidentally disabled display adapter and can't see, safe mode or VGA mode won't work

By the79bomb
Jan 30, 2007
Topic Status:
Not open for further replies.
  1. I just recovered from accidentally disabling my display adapter (*****). I logged into linux to get on the net and found the thread solved by Spike and also by glowingnissan07 on this issue and found that neither of these threads solved the problem exactly. Spikes solution finally ended up working with one change and I thought I would post it here in case anyone else had the same gut wrenching experience (thanks Microsoft).

    Phenomena: accidentally disabled the display adapter and after the XP loading screen you get nothing. Dead monitor. Safe mode hangs each time and "VGA Mode" does nothing different.

    Solution: Here is Spikes original solution (thanks Spike) with a note for step 5. Also beware of "found new hardware" wizard etc popping up at system startup interfereing with these instructions. I recommend pressing alt-f4 a few times after startup to make sure any startup programs get closed and then doing these instructions. Good Luck.

    Log in. If you log in automatically, all well and good. if not...

    1, use the up and down arrow keys to go to your user, and hit enter to select. if you normally have to enter a password, then do it now, and hit enter again.

    2, press and hold the windows key, and tap 'R' (this is the keyboard shortcut to the run box)

    3, type "devmgmt.msc" (without the quotes) and hit Enter (this opens device manager)

    4, wait a few moments to make sure device manager is open, and then hit the TAB key once. this brings the selection onto the device list.

    5, (cancel this step and jump to step 6 with SP2 as you start in device view by type as default and pressing alt-v will pop you into the view menu[new]) hit ALT+V together, which switches to viewing devices by type

    6, hit 'D' TWICE, which should bring you to Display Adapters

    7, hit the RIGHT cursor key to open the dropdown selection, and right again to go to the first device in that selection.

    8, hit Alt+A together to open the context menu for your adaptor (assuming it's the first in the list)

    9, hit the Down cursor key which selects Enable (note, if you've got the wrong device, this will select disable for that device). then, hit Enter to enable it

    10, If you get a number of dialogues, as I just did for a seperate device (I'm not about to disable my own display!!!!), just use a combination of enter/Y (for yes) until they are finished. [I found that pressing Y, Y, enabled the adapter and then proceeded to reboot your system]

    Having speakers on may help for this process, so giving you a few audio cues for what you're doing.

    I just went through this entire process on my machin as I typed it, so I know it works. :) (of course, I know this because I was looking at it. be carefull you don't mistype, or hit the wrong keys!)
  2. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    The shortcut keys in Device Manager apply only to English OS, of course.
  3. ILikePortillos

    ILikePortillos Newcomer, in training

    This works! Thank you so much 79bomb! I made this same mistake, followed your instructions, and I'm back up and running again. You've helped save me some anguish and some dollars as well. Thanks for the helpful tip!
  4. tweakboy

    tweakboy TechSpot Maniac Posts: 518

    Sweet happy ending to this debacle. It's ok everyone does stupid things on their PC, Im glad we saved you. good to hear!!!
  5. kristyo

    kristyo Newcomer, in training

    I also disabled my display adapter (can't believe I did that!) Just wanted to thank the79bomb for the steps to correct the problem!! I'm sure I would have spent lots for someone to fix. Can't thank you enough!
  6. tweakboy

    tweakboy TechSpot Maniac Posts: 518

    Ouch you put yourself in a nice hole by doing that LOL ,

    np we can fix it.

    We need to try booting into VGA mode ,,, not safe or normal ,,, I believe once you get in there you can uninstall drivers which are probbaly not there. Or you can just install the video drivers from there and come back up,,,, gl,
  7. CCT

    CCT Newcomer, in training Posts: 3,556

    Just some thoughts for other opinion:

    - onboard video would be default 'enabled' so if you disabled it in control panel somehow then resetting cmos should reset that.
    - add-on card disabling where no onboard exists could be gotten around by removing that card and inserting a different card for plug and play to detect - then VGA would work again if it didn't when the original card was disabled

    I think

    :)
  8. marcoabc

    marcoabc Newcomer, in training

    narrator

    between step 1 and 2 if you can press windows key then 'R'
    after that type 'narrator' and hit Enter
    then proceed with step 2

    it is a way to get a voice explaining what you are doing...

    bye
  9. onix011

    onix011 Newcomer, in training

    its still not working

    i followed the steps 1 by 1 and nothing happened inform me on anything else i can do
  10. Badfinger

    Badfinger Newcomer, in training Posts: 160

    Reinstall the OS from CD over top of itself might do the trick....

    Otherwise hooking up the offending HD to another system and investigating it's registry or other files will do it, yes a hassle.
  11. Ditzyditzel

    Ditzyditzel Newcomer, in training

    I just tried doing this, but it's still not working!? i've tried a million times.
  12. djsagat

    djsagat Newcomer, in training

    This steps really work

    A suggestion,

    if your speakers are good open the narrator first, here is the shortcut

    Windows key + U
  13. Ditzyditzel

    Ditzyditzel Newcomer, in training

    Thank you, but I just reinstalled Windows, and it worked just fine :) thanks though x
     
  14. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    Keep in mind that this is only for XP. Other Windowses have different user interfaces so these shortcuts might not work (UAC comes to mind).
  15. rkr

    rkr Newcomer, in training

    Okay, I tried this and it did not work. I tried it a second time with the narrator turned on and found out that there was no item in the device manager window labeled 'display adapters'. So I'm still stuck without a display. Any ideas? I am using Windows XP SP3 if that helps at all. Please help. I'd rather not have to reinstall Windows.
  16. Hesperides

    Hesperides Newcomer, in training

    :d :d :d

    Thank you soooooo much!!!! It helped )))) though my system is in russian, i don't ve the slightest idea how it all worked out, but it did)))) thank you thank you thank you!!!! I'm soooooo happy!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Thanxs
  17. EvanO032

    EvanO032 Newcomer, in training

    Thank you so much. This was an amazing peice of help. You saved me quite a bit of money. Im so happy thank you very much 'The79Bomb' Your an absolute legend.
  18. casperld

    casperld Newcomer, in training

    I had to sign up just to tell you THANK YOU!!!!. Using the narrator was the key for me, that and also practicing on a computer that i could see, so I could visualize what the "robot" narrator voice was saying.

    THANK YOU!!!!!
  19. rockalittle

    rockalittle Newcomer, in training

  20. PositronBG

    PositronBG Newcomer, in training

    Thanks

    THANK YOU SO MUCH.
    It really helped me. :)
  21. justinwilkinson

    justinwilkinson Newcomer, in training

    Hi. I have the same problem - my display driver is disabled. I went through all the steps (even turning on narrator) and when I went to enable my display driver, it didn't have the option to enable - it only said disable (as it if weren't disabled at all). So, do you have any options for me? Please reply. Thank you.
  22. tweakboy

    tweakboy TechSpot Maniac Posts: 518

    I smell a format clean install

    Sorry for your troubles..

    Or try

    repair install ,, u can try,, good luck,
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.