TechSpot

acer laptop has problem loading dvdrom, (driver error: code 39)

By awsskater892
Apr 11, 2007
  1. Hi, My sisters laptop is not working correctly. It is fairly new, she got it about a month ago. It is an Acer laptop, model #: aspire 5570z, with Windows Vista Home Basic. processor: INtel T2060 @ 1.6GHz, ram: 502MB, and is 32-bit OS.
    The problem is that the dvd disk drive is not showing up in my computer, this problem happened yesterday randomly. After seeing this i went to device manager and it showed up so i went to the properties of it, and it says:

    windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)
    Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available.

    So I tried this, and nothing happens, it just comes up with a box that says sending solution with a little loading bar, it loads, then it goes away.
     
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Uninstall the driver, and then click Scan for hardware changes to reinstall or upgrade the driver.
     
  3. awsskater892

    awsskater892 TS Rookie Topic Starter Posts: 96

    do you know where i would get the updated driver?
     
  4. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Acer site should have the drivers.
    You can also look on the bottom of the drive... often with the Acer, the drive is a TEAC so you can get them at the Teac site.
    It sounds to me as if the drive has gone bad. Since it is a new computer, you need to talk to ACER before you do anything that could void your warranty.
     
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    The cd driver SHOULD be built in to Vista (just like it was in XP).

    Do the uninstall, shut down, and reboot and see if it finds the driver.
     
  6. CraigMc

    CraigMc TS Rookie Posts: 29

    Failing that, call Acer support - it may be a known bug :)
     
  7. k_shezad

    k_shezad TS Rookie

    Solution to your problem!

    Hiya,

    I've had the same problem. Use the following to sort it out.

    support.microsoft.com/kb/314060/EN-US/

    Cheers

    k_shezad
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...