TechSpot

AGP Fast Write on Radeon 9800 Pro

By uNreal
Oct 30, 2004
  1. hey, can some1 tell me, should i put Fast Writes ON or OFF ? I have Sapphire Radeon 9800 Pro 128 mb, and i had this option turned to OFF on my old system, because i read somewhere that only Radeon 9600 users should put this function and also i had FPS problems in Counter-Strike, and i read in some article that i had to put fast writes in BIOS to OFF to increse the performance and so on. I had the same video card, on AthlonXP 2000+ . Now i have Athlon64 3400+ with 512 ram and EpoX mobo. And SMARTGART put fastwrites to ON automaticly. So what should i do ?
    I think it is not connected to fast writes, but still, i have some problem:
    on the old computer i had some fps problems in new games, how it should be, but on Counter-Strike ( in places, where fps is 100, i had problems only on some maps like aztec, etc. ) , and all other games that should run well on that machine, i had 100 fps an games ran smoothly. But now, i have more than 100 fps on every game i play, for example - CS Condition Zero, it's like 200 fps, but still the game isn't smooth, when i run forward and look at the floor, it stutters or something, i can't explain that, but it looks like i have 40 fps, but the meter shows 200+ . In Unreal Tournament 2004, when i play instant matches, the fps is also more than 150, and everything is ok, but when i play online, the fps is limited to 85 in online play, i encounter EXTREME tearing, and also this "non-smooth" problem, like in cs-cz...
    I tried putting Vsync to ON, and it removed the tearing in UT, but the the problem still exists... Any ideas ?
     
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

  3. uNreal

    uNreal TS Rookie Topic Starter Posts: 23

    hmm... actually, that manual didn't give me any answers.
    My Radeon 9800 Pro isn't listed there, so it means that it doesn't support fast writes ? or what ?
     
  4. Justin

    Justin TS Rookie Posts: 942

    I'm using an A7N8X-E Deluxe with a Sapphire Radeon 9800 Pro - Fast Writes are enabled and it works great.
     
  5. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    My system was very unstable with FS on.
     
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Quote from Unreal
    hmm... actually, that manual didn't give me any answers.
    My Radeon 9800 Pro isn't listed there, so it means that it doesn't support fast writes ? or what ?"

    I believe Ati writers just got tired >the last 3 sentences clearly would imply your card is included;
    "
    A3: Yes. The RADEON 9700 PRO, RADEON 9700, RADEON 9500 PRO, RADEON 9500,
    RADEON 9000 PRO, RADEON 9000 and the RADEON 8500 are capable of supporting
    fast writes when using an ATI CATALYST based display driver. Of course fast writes
    must also be supported on the motherboard you are using and be enabled in the
    system BIOS. In order for fast writes to be used by ATI’s driver, fast writes must also
    pass the SMARTGART diagnostics test. ATI products previous to the RADEON 8500
    as well as the RADEON 8500 DV are not capable of supporting fast writes."

    You should have no trouble !
     
  7. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    ATI's "SmatGart" will automatically determine if you system is stable with Fastwrites enabled. It will automatically enable or disable them...depending on the rest of your system...
     
  8. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    PreservedSwine;
    I just gotta ask.Are u smoked,pickled or salted?
    Luv your Handle.
     
  9. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    Given the options, I prefer pickled :chef:
     
  10. tweakboy

    tweakboy TS Guru Posts: 467

    On those cards,, mite help compabiiltiy and stability ,

    Usually you want it left ON,,

    gl,
     
  11. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    This thread is from 2004 lol :)
     
  12. fzap

    fzap TS Rookie

    HERE is the KEY to this ANNOYING PROBLEM

    After pulling out my hair for days (will I buy another radeon card? you guess)

    Here is the answer

    ----------------

    FIRST GET RID OF SMART GART, GOOGLE "SMART GART UNINSTALLER" DOWNLOAD AND RUN.

    HKEY_LOCAL_MACHINE\Software\ATI Technologies\CDS\0000\0\Memory

    Block Write Support default Yes..... select 0, No =)

    (change Yes to No and the 1 to a zero)

    Now go change all the "fast write" entries (regedit search) from No to Yes (0 to 1) and they should STAY THAT WAY.

    Now you have Fast Write support =)

    This is a Windows XP tweak BTW, im not sure if it will work in NT; WORKS GREAT WITH WIN98

    --------------

    BTW, HERE IS THE ANSWER TO THE HEADACHE GENERATING 60Hz REFRESH RATE BUG

    Start regedit, go to HKLM/Software/ATI Technologies/Driver/0001/DAL (or instead of 0001 whatever number your current driver uses).
    Insert a new binary value, named "DALRULE_ALLOWNONDDCCRTALLMODESUPTO1600x1200". Set the value to 01 00 00 00.
    Or, you could try "DALRULE_CRTSUPPORTSALLMODES" and set this to 01 00 00 00 instead. (Both work here perfectly, the difference being that one allows resolutions up to 1600x1200x200, the other 2048x1536x200.
    That's it, just reboot.

    IMPORTANT: you need to set the refresh rate for all resolutions you want to use manually with regedit, since the driver will likely set them to 200hz when you switch resolutions, so you won't get a picture unless your monitor can handle that. So, go to [HKLM\System\CurrentControlSet\Services\Class\Display\0000 (or whatever number your monitor has)\MODES\x\y,z]. Make a new string "RefreshRate" and set it to "85" or whatever you like and your monitor can handle.
    If you forget to do this you might be forced to boot in safe mode since you might get an "out of range" value by your monitor upon boot-up...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...