TechSpot

Amazon issues emergency update for older Kindle e-readers, install ASAP or lose your web connection

By Shawn Knight
Mar 21, 2016
Post New Reply
  1. Amazon has issued a critical software update for select Kindle e-readers that must be installed by March 22, 2016, in order for the device to retain its connection to the Internet.

    The full list of affected Kindle e-readers is listed below:

    • Kindle 1st Generation (2007)
    • Kindle 2nd Generation (2009)
    • Kindle DX 2nd Generation (2009)
    • Kindle Keyboard 3rd Generation (2010)
    • Kindle 4th Generation (2011)
    • Kindle Touch 4th Generation (2011)
    • Kindle 5th Generation (2012)
    • Kindle Paperwhite 5th Generation (2012)

    For newer devices including the Kindle Paperwhite 6th Generation (2013), Kindle Voyage 7th Generation (2014) and Kindle Paperwhite 7th Generation (2015), no update is needed.

    Those that fail to update by tomorrow will receive the following message when attempting to download Kindle books from the cloud, access the Kindle Store or use other Kindle services:

    Your Kindle is unable to connect at this time. Please make sure you are within wireless range and try again. If the problem persists, please restart your Kindle from the Menu in Settings and try again.

    Amazon notes that devices that are asleep and connected to Wi-Fi should download and install the update automatically. This, of course, is assuming the e-reader isn't tucked away in a closet or drawer / still has some juice left in the battery.

    Should your device not automatically grab and install the update and / or you forget to grab it by March 22, you're not entirely out of luck. At that point, you'd need to manually download the update on a computer and transfer it to your Kindle via USB cable. More information on the procedure can be found on this Amazon help page.

    Permalink to story.

     
  2. Dustyn

    Dustyn TS Enthusiast Posts: 40   +11

    Why in the hell is this such an EMERGENCY to begin with?
    How is it that such a bug was not discovered until there is just days left to address the problem?
    Crazy!
     
    jauffins likes this.
  3. Puiu

    Puiu TS Evangelist Posts: 1,902   +528

    it's not a bug. they are intentionally blocking the connection of those that don't update.
     
  4. user 666

    user 666 TS Rookie

    It's not an emergency, and it's not a bug. Amazon started telling us about the required update about a month and a half back. According to the people who took the update apart, the only change is to a few security certificates.
    http://the-digital-reader.com/2016/...that-you-update-your-old-and-very-old-kindle/

    - Nate, editor of The Digital Reader
     
    Puiu likes this.
  5. Arris

    Arris TS Evangelist Posts: 4,606   +287

    They sent me a letter in the post telling me about this! A real paper letter. I assumed it was dead serious....
     
    Panda218 likes this.
  6. user 666

    user 666 TS Rookie

    Amazon started sending those out last week, yes. I didn't get one but I've heard from several people who did.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...