TechSpot

AMD 8350 Not getting correct speed

By anttg408
Jan 3, 2014
Post New Reply
  1. So I just installed my 8350 about two days ago and I just found out that it isn't running to its full potential. It's running at 2812 MHz. when it should be running at at least 4k MHz. I tried running my game to see if it will go up and maybe its just idle to save power but that did not work. Then I went into my bios and turned off all my C-State (c1e, c6 are the only two I have). And that did not do the trick and I have ran into a brick wall. Please help me.
     
  2. JC713

    JC713 TS Evangelist Posts: 7,018   +912

    I have 3 possible solutions to the issue: 1) The CPU is flawed. 2) You are in a power saving Windows state. 3) Your CPU is running hot, which will throttle its speed to something lower.

    In order to check whether your PC is in a power saving mode, go to the start menu and type in "power options". Choose the one listed under "control panel". Once you click it, it should bring up a window that tells you what power state you are in. Choose the "Balanced" plan if it is in power saving mode and see if that helps.

    Secondly, download and run RealTemp and tell me what the CPU temperature is at idle and when gaming.
     
  3. GhostRyder

    GhostRyder TS Evangelist Posts: 2,260   +541

    Where are you seeing this clock speed, in the bios or where? Sometimes the CPU when not doing anything will clock to around there with AMD's low power state system (My previous 8350 did this quite often till I overclocked it). But as @JC713 hit everything that needs to be checked, follow his guide, that should find a fix for you.

    The only other possible thing I could think of is the motherboard may need a bios update.
     
  4. anttg408

    anttg408 TS Rookie Topic Starter Posts: 45

    Actually it turns out my mobo did not support it. So I bought a Gigabyte 990 fx ud3 and I installed it. The CPU seems fine and the every seems to be connected. I have a Rosewill rp600v2-s-sl. This is my first time installing a mobo. I have no clue what's going on. I press the power button and it literally powers on for half a second then instantly turns off . I triple checked the CPU, and PSU connections. I just want to know a few things. Can my mobo power on at all if it isn't functional? Is my CPU messed up? It's brand new. Or did my PSU fry?
     
  5. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    The motherboard could be shorting against the case. Did you use motherboard standoffs? If so, make sure any old standoffs are positioned correctly according to the new motherboard. It's possible an old standoff is in the wrong place and is shorting against the new motherboard. Of course, when I refer to old standoffs, I mean standoffs in their old positions. You don't get new ones with a new motherboard so you might have to rearrange some of the original ones.

    Another thing you could try is to remove the motherboard from the case with the power and data cables connected and place it next to the case on a non-conductive surface and see if the PC will start. For purposes of this test you may leave the hard drive and optical drives disconnected. Of course, you should unplug the PSU or place the PSU switch to the "off" position when moving the motherboard.
     
  6. anttg408

    anttg408 TS Rookie Topic Starter Posts: 45

    Oh that must be it then. Some standoffs are not in position there are about 2-3 that are just under the mobo but not screwed in because My new mobo is slightly bigger than the old one.
     
  7. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    It's important that any standoffs line up with the new motherboard's mounting holes. Don't leave any standoffs in their old positions unless they line up with the new motherboard's mounting holes. If the new motherboard has more mounting holes than you have standoffs or if the case doesn't match up with all of the new motherboard's mounting holes, space them as evenly as possible as best you can.
     
  8. anttg408

    anttg408 TS Rookie Topic Starter Posts: 45

    Okay I will be removing it in a bit and will tell you how it goes!
     
  9. anttg408

    anttg408 TS Rookie Topic Starter Posts: 45

    I removed it and put it on top of a non conductive surface and tried it power it on and it does the same thing. So my mobo short circuited for sure then?
     
  10. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    No, if it started normally, then it would have meant that it probably shorted to the case. Since it did not start, it appears that it wasn't shorted to the case.

    When you installed the CPU to the new motherboard, did you clean the CPU and heatsink and apply fresh thermal compound?
     
  11. GhostRyder

    GhostRyder TS Evangelist Posts: 2,260   +541

    Could you post a picture of your motherboard hooked up. We may see something that you didnt see before.
     
     
  12. anttg408

    anttg408 TS Rookie Topic Starter Posts: 45

    I tried my old mobo to see if it would work and it did.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.