AMD Catalyst 13.12 WHQL drivers released

By Scorpus
Dec 19, 2013
Post New Reply
  1. It's that time again, where those with an AMD Radeon graphics card get to update their drivers to a new version. Catalyst 13.12 was released yesterday as a WHQL-certified driver, available on operating systems from Windows Vista to Windows 8.1.

    Read more
  2. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    Where is that Mantle they promised.
    St1ckM4n likes this.
  3. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    Nice, ill be downloading this when I get home!
  4. JC713

    JC713 TechSpot Evangelist Posts: 6,144   +739

    I tried downloading and installing these yesterday with no prevail. The one I downloaded from the desktop site downloaded and the Catalyst install manager came up, but didnt detect a new driver (even though I am still on 13.9). I tried the mobile one (I have a laptop), that one didnt even download a driver, it just downloaded a 45kb file and said it finished downloading...

    And... why is there no mention of any BF4 performance improvements? The game has been out for almost 2 months. AMD should have done some optimization by now.
  5. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    I think in the previous 4 beta iterations they were focusing on ironing out the bugs and crashes. at least from 13.11 beta 7 all the way to beta 9.4, my game no longer crashes. it'll be nice if they can make some progress on optimization, AKA Mantle that was promised to be released in December.
  6. Eddo22

    Eddo22 TechSpot Enthusiast Posts: 134

    Your not the only one to notice that JC713. I upgraded from 13.4 and it's still showing 13.4. I would recommend using AMD Cleanup Utility if on Windows 7. Be Advised: I don't know if Windows 8 is still having problems with AMD Cleanup Utility and add/remove programs or not.
  7. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    The Mantle Optimization is set for end of December now as ive heard/read. As far as the game running well, ive got Quadfire HD6990's maintaining a steady 45-60 FPS in Eyefinity Mode.

    Odd, not sure then, let me try when I get home, im running on beta 13.11 I think 8 so let me see what happens.
  8. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    I am running my game 45~60fps as well @2550X1440 Ultra. but that doesn't mean there's no room for improvement.

    I was already running 45~50fps during first year of BF3, but over the years ATI improved their drivers and I was able to run it at 65fps at the same settings.
  9. amstech

    amstech TechSpot Enthusiast Posts: 761   +178

    Great screenshot! I just beat Last Light (8 hours 16 minutes), it was pretty fun...clunky, sometimes weird, but fun. Much better when you fight along side the little alien dude! My 670 ran it on Very High/+Tess/16X AF (no SSAO) @ 1600p very well. I let GeForce experience optimize the game, 45-60FPS (thanks again to my good friend FRAPS) throughout and quite smooth.
    St1ckM4n likes this.
  10. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    When I first started BF3, I had a pair of PNY GTX 580 LC editions (Those ones with all in one LC attached) keeping the game around on a 1080p screen at Ultra 60FPS, but decided I wanted more GPU power with Dual GPU cards when I grabbed 3 monitors and because newegg messed up my order, I could no longer order GTX 590's because of stock problems. Ended up with a pair of HD 6990s which I added liquid blocks to later and with that I keep 60FPS on ultra with the DUO running in Eyefinity mode. BF4 is the first to not keep a constant 60FPS on Ultra in Eyefinity mode (Turning down AA seems to help but im a nut for quality) though bumping my core clocks to 980mhz seems to do the trick, ive decided to upgrade. Theres room for improvement for sure, but im actually shocked at how well they run in Quadfire on it, the drivers are actually doing quite a nice job keeping Eyefinity and running on ultra while maintaining above 45 FPS which I consider to be a good area (Overclocked I get 55-60 it seems pretty constant with a few spikes in the big maps).
  11. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79


    I have my HD7950 overclocked from 725mhz to 1200mhz core, and 1250mem to 1600mem since the day it came out. and my 3770K is clocked from 3.5ghz to 4.8ghz with a custom water loop (single 360mm rad up top, single 120mm rad in the back with industrial D5 pump). but you have to remember, the majority of the population don't have the kind of power that you and I enjoy. so you and I can afford running high res at 60fps, most of the people I talk to with average systems struggle to keep up at 30fps in medium settings. compare to BF3 performance, BF4 still has a long way to in terms of game/driver optimization.
  12. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    Just came home and installed 13.12. having the same problem. the driver installed, but somehow catalyst info still says 13.11 even tho device manager confirmed the display driver version has been updated. nice job AMD. tried clean install the same thing.
  13. tomkaten

    tomkaten TechSpot Enthusiast Posts: 65   +25

    Same for me, Howzz. It installed fine, reports the old version number. I don't care though, as long as it works :)

    [​IMG]
     
  14. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    ok... after ****ing around with it for god knows how many hours. it's not my fault. something is wacky with this release. I tried uninstalling all the ATI drivers, installed the new one. and Catalyst wouldn't even display a version number, after burner just leaves the version number blank. however, if you look at device manager, it does say the display driver version is 13.251 as oppose to 12.250.18 (13.11 beta 9.4 I was using).

    it may be just me, but I noticed it ran not as well in BF4, so I reverted everything back and installed the last 13.11 beta 9.4 I was running.

    and before you say anything, tons of people on guru3d, and techpowerup are having the exact same issue, and poor fellas also tried exactly the same thing I did and came to the exact same conclusion. ****ing a, wish I had read their posts instead of wasting hours of my time.
  15. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    Your right, there's some bug it seems with the displayed version, though I know it is the new version because like you said it displays that driver version in device manager, just not in CCC. Odd bug, they must have been missed that somehow in the debug :p. I ran BF4 last night and it seemed fine to me honestly, I didnt see any performance jumps or drops so it really stayed exactly the same to me. The only game I did notice something was since they put it on the cover of this driver I tried Metro Last Light and it seemed to improve across the board, I cant run it in Ultra still with Eyefinity running, but it did run better all around mostly because it didn't hover at using only 30-50% of my 4 GPU's and actually punched the throttle a bit more. Didn't care enough to try any other games, but whatever seems like a good release to me excluding the stupidity of a bug like that.
  16. howzz1854

    howzz1854 TechSpot Maniac Posts: 585   +79

    Maybe the server I was playing on last night in BF4 was laggy. like I said I wasn't sure if it really did perform worse. maybe I'll give it another shot tonight when I get home. but it's good to hear that Metro got a bit of a boost.
  17. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    Indeed, though I still cant run it in eyefinity and keep a rough 60 on Ultra settings sadly :(. That probably wont happen now till I get either my tri-fire 290X setup or the Rumured Mt. Vesuvius Dual GPU card.

    But since that was the headline of 13.12, felt like I had to try that game and see if it really did go up more than like 5%. I always ran it at ultra before, now its a much more steady 60FPS it seems which is what I wanted.
  18. JC713

    JC713 TechSpot Evangelist Posts: 6,144   +739

    I tried to uninstall it manually through the add/remove programs, but when I went to install it, it didnt detect my GPU... ugh AMD...
  19. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    That's odd, I didn't have that problem at all, all I had was the showing 13.11 on the display. Everything else was working like a champ, what gpu you running again @JC713
  20. JC713

    JC713 TechSpot Evangelist Posts: 6,144   +739

    ATI Mobility Radeon 5730
  21. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    Odd, im guessing you got it to work now correct? But for me I did not have any problem uninstalling then re-installing the driver.
  22. JC713

    JC713 TechSpot Evangelist Posts: 6,144   +739

    When I uninstall, it works. But then, when I go to install, it doesnt detect my GPU.
  23. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    Quite odd, maybe its something to do with that series of GPU or mobile, not sure honestly sorry bro. I tried completely uninstalling and full clean install on my system and it picked up my 6990's, dont know what the problem is, is it being reported elsewhere?
  24. JC713

    JC713 TechSpot Evangelist Posts: 6,144   +739

    So I searched up on the AMD Forums and I found that a lot of other people are having the same issue with the mobility driver, where it just downloads a 45 kb file. Well, someone provided me with a direct download and it works! So my issues are solved @GhostRyder.
  25. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,860   +402

    @JC713 So it was the mobility driver, ok cool glad it got fixed!


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...
Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.