Amdk8.sys (AmdK8+0x3552)

  1. I am stumped recently while playing any game 10-20 min in it crashes,last week I was tinkering with my computer and figured it was over heating I took out my graphics cards to check if all my fans were working and what not yes they were than something on my motherboard sparked and smelled nasty so my monitor wasnt showing up I bought a new MSI video card and I was all exsited to play with it and now like I said every 10-20 min it crashes Iv done everything under the son monitoring my temps reinstalling drivers all of the above that you can suggest I am frustrated to the point im ready to give up lol anyways I did a who crashed Analysis and this is what came up my crash count is like 10 times any suggestions or anything is greatly appreciated.

    On Mon 10/17/2011 3:03:16 AM GMT your computer crashed
    crash dump file: C:\WINDOWS\Minidump\Mini101611-05.dmp
    This was probably caused by the following module: amdk8.sys (AmdK8+0x3552)
    Bugcheck code: 0x1000000A (0x0, 0xFF, 0x0, 0xFFFFFFFF806E5EA0)
    Error: CUSTOM_ERROR
    file path: C:\WINDOWS\system32\drivers\amdk8.sys
    product: AMD Processor Driver
    company: Advanced Micro Devices
    description: AMD Processor Driver
    A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: amdk8.sys (AMD Processor Driver, Advanced Micro Devices).
    Google query: amdk8.sys Advanced Micro Devices CUSTOM_ERROR
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    Amdk8.sys is a AMD CPU driver. That burning smell might also be a sign the the motherboard as well as the graphics card was damaged. Did you pull the video card with the power still on?
  3. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    No the power was off and unplugged my graphics cards were damaged I bought a new graphics card everything is up and running perfectly but this one bsod I am getting oddly the power was off when it fried my sli graphics cards
  4. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    I bought a new MSI frozer 3 so my games are now running impeccably lol but that one cpu system driver keeps dumping after 10 min oddly enough I figured that my computer was spreading the voltage out wrong which was dumping it so I unplugged my cd rom and yeah witcher 2 which is a game ran for about 10 min longer but than dumped with no sign of bsod or anything I also opened my performance tab and monitored my cpu I also used a program called everest to monitor my tempatures and they seem to be perfectly fine my mother board is a steady 53-55C
    my cpu stays at 45c so I dont think its over heating
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    2 video cards were fried at the same time? Are you still getting the amdk8.sys error?
    Try resetting the bios to their defaults
  6. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    Yes both my sli's were fried when my motherboard lit up my mothboard is working great I am getting that system error yes and I did flash my Bios as well I deleted my processors and reinstalled the chipset and I also made sure they were no over clocked I got a brand new graphics card so everything is working great besides that one system file
  7. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    Oh and btw this amdk8.sys bsod was happening previous to my cards breaking if that helps at all it was happening 2 years ago and than stoped doing it and now it started to happen again its really weird
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    Try another power supply just for testing purposes
  9. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    I can try that but it may take me awhile because I have the highest power supply on this computer out of all of my computers is there any other solutions u can think of? to fix the amdk8.sys error?
  10. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    I manually flashed it but I have a m2n-sli and it hasnt been updated sense I got it so I probably need to update it but Idk how to update a bios and I hear if you mess it up u mess ur computer up
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    I thought you already flashed the bios... Any power supply might be okay to test with as long as it has the proper connections. Wattage may not matter here. You don't have to keep adding new posts to your last post, just edit the last one created
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    Go to the motherboards manufacturers website and look under "drivers" for a bios update. There will be instructions there
  13. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    You mean my system.exe?
     
  14. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    Delete the CPU in the device manager and see if it is picked up correctly after a restart
  15. oderlessmanatee

    oderlessmanatee Newcomer, in training Topic Starter

    By the way I fixed the bsod error because I somehow fixed my registry and also little did I know there was a video card driver update altho when I play any intensive game
    for some reason after 30 min or so my computer will freeze and shutter my sound so my theory is over heating? When I look in my Event Viewer I do see two occuring application errors called load perf event id:3011 and 3012


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.