TechSpot

AMI BIOS Problem

By jools1976
Feb 23, 2010
  1. Hey folks, I have a problem here I'm hoping to get a hand with. I recently had an MSI M677 notebook with an AMI A1633NMS BIOS go pretty much dead on me. The power would still turn on, and the CPU fan would run, but that's it. No audio, no video, no beeps....nothing. After about a week of troubleshooting and otherwise messing around with it, I ended up using a POST code reader to come up with the following error code:

    F1 -- The AMIBOOT.ROM file is not in the root directory

    I then went to the MSI website and got the most recent BIOS for the notebook, and followed these steps:

    1.Rename the desired AMI BIOS file to AMIBOOT.ROM and save it on a floppy disk. e.g. Rename A569MS23.ROM to AMIBOOT.ROM

    2.Insert this floppy disk in the floppy drive. Turn On the system and press and hold Ctrl-Home to force update. It will read the AMIBOOT.ROM file and recover the BIOS from the A drive.

    3.When 4 beeps are heard you may remove the floppy disk and restart the computer.

    The only thing I did differently was use a USB stick instead of a floppy, and I heard no "4 beeps". I had no video so other than the activity light on the USB stick I had no way of telling what progress was being made on the reflashing. I left it about 20 - 30 minutes, rebooted, and everything worked perfectly. Now... I was using the laptop without a bettery (plugged into AC power), so after I got everything fixed up, I turned it off and put it aside for a few hours. I came back to it later and when I went to start it up, I had the same problem as before. I checked the CMOS battery and it was completely dead. I replaced it with a new battery, but now the flashing won't take. I am following the exact same steps I follwed before (that worked) but for some reason the activity light on the USB stick just keeps cycling on and off (in about 5 second on/off intervals). I've repeated the process 5 or 6 times, but nothing seems to work. I've left it running for over an hour... no flash. Can anybody help? Thanks.
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The CMOS/Bios chip on the motherboard may have "burned" out... A new motherboard may be the only solution
     
  3. jools1976

    jools1976 TS Rookie Topic Starter Posts: 21

    Yeah I'm starting to think that.... One thing I did notice though is this... The BIOS file from MSI is called A1633NMS and it's a 709 file. Following the directions I posted above (that worked for me before) I rename it to AMIBOOT.ROM and flash away. I'm pretty sure when I changed the name before it also changed the file type to a ROM file. I don't even know what a 709 file is, but whenever I rename the BIOS file to AMIBOOT.ROM now it keeps it as a 709 file, and just changes the name. Think that's why it won't flash?
     
  4. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    That could very well be the case. I am unfamiliar with the naming conventions of low level things like BIOS but I doubt they work they do in the OS. When you download the file does it show up as a .rom in windows?
     
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    jools1976,
    Does the MSI website tell you to rename the bios file? I haven't had to do that for many years
     
  6. jools1976

    jools1976 TS Rookie Topic Starter Posts: 21

  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Are you telling us that you are still running Windows Me? No wonder it has been many years for me... I was probably working with a Windows 98SE or Windows Me system when I last had to rename a bios file. Good luck
     
  8. jools1976

    jools1976 TS Rookie Topic Starter Posts: 21

    Windows Me? No... What gave you that impression? It's Vista (when it'll boot up lol)
     
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your link to updating the bios shows Windows Me on the monitor screens shown in the instructions... Unfortunately, Vista is as poor as Windows Me was as far as Windows Operating Systems go
     
  10. jools1976

    jools1976 TS Rookie Topic Starter Posts: 21

    Oh...gotcha. I never even noticed that... good eye. I guess those directions must be older. But either way, I'm not even getting to a POST screen, let alone an OS. Have you ever heard of a 709 file?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...