Annoying Geforce FX 5200 gamin problem

By plus
Jun 22, 2005
  1. Hi,

    I recently upgraded to a Geforce FX 5200 128mb AGP card. I bought it to improve gameplay. Although it has made the game look and play better from my previous GeForce MX/MX 32mb card it has caused more problems.

    I used to get the blue screen of death, that was fixed by using the drivers from nvidia instead of the cd. Now, instead of the blue screen after a certain event in a game such as engaging combat or something the graphics seem to go weird. As if there are no textures. An example is when I play rouge spear rainbox six after a certain amount of time the walss suddenly go pink. The flor goes multicoloured. I can't really describe it better then that.

    What could be going on? My motherboard only support 4x AGP speed so where it says set the speed to a lower setting still doesn't help. I decreased the hardeware acceleration but it seems the lower I put it the worse it becomes.

    Anyway other then that this card is really good. Thanks for any help.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    apply all of the latest patches and updates available for your games, and all device drivers on the computer.
  3. plus

    plus TS Rookie Topic Starter

    Ah, thanks. I updated all of the device drivers but I never thought of the actual game patches. I will do that.

    Although it has happened to a game that I have all the updates for. But it doesn't happen as often. Is there anything I can change such as a setting that could do it? Or does it all boil down to the device drivers?

  4. IronDuke

    IronDuke TS Rookie Posts: 856

    Have a search through Techspot. Not always are the latest drivers the best.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...