TechSpot

Another Home Networking Problem!

By marine105
Oct 9, 2006
Topic Status:
Not open for further replies.
  1. I have successfully connected my "newer" XP Home machine to my ancient W98SE. Logged in on both with the same user name/password & Guest Account enabled on XP, if I sit at XP I can do anything: transfer files in both directions, whatever.

    But from W98SE, although I can see XP on Network Neighbourhood, if I try to access it I get "You must supply a password to make this Connection"
    Resource: \\(name of computer)\IPC$.

    If I input the password with which I log on to both machines I am told it is incorrect!

    I connect to the internet with Broadband through the XP machine only. The W98SE machine cannot access the internet: I was hoping to be able to do this through the XP, but guess this will be impossible until I can overcome this password problem.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,845   +165

    "I connect to the internet with Broadband through the XP machine only. The W98SE machine cannot access the internet: I was hoping to be able to do this through the XP, but guess this will be impossible until I can overcome this password problem."

    You need to be using a crossover type network cable and you also have to enable Internet Connection Sharing on both systems, especially on the Windows98 system... XP is a little more "automatic" than Win98 when it comes to network setup
  3. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Yes I have a crossover cable. I believe Internet Connectio Sharing was taken care of when I ran the Network Connection Wizard on XP, followed by running the resulting floppy on W98., but surely this would not have a bearing on W98's demand for a password before it can even access files etc on the XP???
  4. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    two issues: Internet access and Sharing.

    sharing:
    check your workgroup name under the CP->System;
    XP defaults to XPHOME while Win/98 defaults to WORKGROUP
    change one to match the other :)

    Internet Access:
    on XP, run cmd /k ipconfig /all, note the DNS address

    On Win/98, try to ping that DNS address,
    until this works, you will have no Internet
  5. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Same workgroup name on both, and yes, I can ping XP's the DNS address from W98.

    And anyway surely if these items were not correct, I would not be able to access W98 files etc from XP? Everything works fine in one direction, but not in reverse.
  6. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    We know your computers communicate fine. That's a great way to start off. :) This means your cables and network configuration -as far as file sharing is concerned - are just peachy. This is a Windows problem.

    Let me know if you've tried this, but it looks like to me that you need to log in under the same account name.

    For example, if you're logged into XP under 'JimBob', you need to log off the Windows 98 computer and login as 'JimBob' at the login prompt. Once your desktop loads under 98, go to the computer and it will ask you for your password. Type in the same password that's used on the XP computer and it should let you in.
  7. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    this should be your ISP dns address and not a local LAN address like 192.168.*.*
    sorry, not so. File Sharing is independent of the routing to allow your Win/98 to pass thru XP to the Internet.
    As you can ping the (isp) DNS, it would appear that your routing is also working.

    What permissions did you set on the shared folder(s)?

    My W/98 works by MAPPING a Drive, but not by the \\(name of computer)\*sharename*.
  8. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    the ms kb setup article is here

    in addition, there are issues documented here
    Here are some points to ponder when deciding whether to use ICF on your network connections.

    WARNING #1: As its name implies, the Internet Connection Firewall is for use ONLY on a direct connection to the Internet, such as a dial-up, DSL, or cable modem. If your computer gets its Internet connection through a software router (like Internet Connection Sharing) or a hardware router, you don't have a direct connection and must not enable ICF.

    WARNING #2: If the Internet Connection Firewall is enabled on a local area network connection with other computers, it will block File and Printer Sharing. This is probably the most common problem in Windows XP networking.

    WARNING #3: ICF is only effective against undesired incoming traffic from the Internet. It can't stop undesired outgoing traffic from spyware, Trojan horse programs, or other hacker tools. If you want outgoing protection, use a firewall that offers that capability, and disable ICF on all connections.

    WARNING #4: To enable or disable ICF, you must be logged on as a user that is a member of the Administrators group.
  9. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Lot's of good ideas to try: I'll try to deal with each, and meantime many thanks to all!

    I said in my thread opener that I log in on both with the exact same user name and password.

    JoBeard: No, I pinged the wrong DNS yesterday (listed under "Internet NIC" and starting 192.168.....
    Below this is listed another 2 DNS addresses under "PPP adapter Internet ADSL". These both start 80.225.***.***, and I cannot ping either from W98.

    To be clear, you think I have two separate problems?
    1. Cannot access Internet from W98
    2. Cannot access XP files from W98.

    I have the whole of my XP C-drive enabled for sharing, and likewise both hard drives on W98. I know this is risky but thought I could tighten up after I get everything working. As I have XP Home, I understand Simple File Sharing is enabled by default?

    Re ICF, I have Windows Firewall off. I use ZA. Now this may not be configured to allow access from W98, but if it were not, wouldn't it block access with or without a password? If you think this is the problem, any advice on how to configure, please?

    I don't understand what is MAPPING. Can you spell it out for me please?

    Looks to me now like either my firewall is too rigorous or there is some as yet undiscovered problem with W98?
  10. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Yes, I think you do. Problems sharing files with 98 and XP are very common. ICS is a whole other sack of batteries, so work on getting one fixed at a time. The only way it could really be both of them is if you have no network connectivity whatsoever, which isn't the case since you can share files.

    I would be interested in seeing an ipconfig /all from each computer. Post the information here. Start > Run > command.exe for 98 and Start > Run > cmd.exe for XP.

    If you're using ICS, you obviously have to configure your network information manually. It should look something like this.

    XP computer
    Local IP: 192.168.0.1
    Subnet: 255.255.255.0

    98 computer
    Local IP: 192.168.0.10
    Subnet: 255.255.255.0
    Gateway: 192.168.0.1
    DNS: 192.168.0.1

    If you're numbers don't look like this, feel free to change them and try what I have posted above. You'll most likely need to reboot the 98 computer after the changes. You may also want to uninstall and reinstall your network adapters on the XP machine to kind of 'reset' the tinkering you've already done.

    The best way to configure ZA at the moment is just disable it while you troubleshoot. We can worry about ZA later. :)
  11. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    I'd been thinking about the ZA firewall and realised it was some time since I'd tried disabling it, so tried again, and BINGO!, W98 can now access the Internet. So to wrap this one up I just need to figure out how to configure ZA to allow W98 access.

    Regrettably disabling the firewall has not allowed W98 access to XP's files: I got the exact same notice quoted in my opener.

    I'm sorry Rick, but when I call up the ipconfig /all on both machines the "copy" function is greyed out so I cannot paste the results. How do I fix this, please?

    What I can say is that the Network info is pretty much as you suggested it should be on both machines.
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    as shown earlier, you will need to DISABLE Windows Firewall, enable ICS,
    and then configure ZA on your XP like this;
    ALLOW 192.168.0.2 tcp/udp in/out ports 139,445​
    and force W98 to an address of 192.168.0.2

    debug your networking here

    tool menu->map network drive->browse->
    ...Netwk Places->entire net->MS Windows Net->$your-workgroup-name

    you should see both XP and W98. expanding each via the + sign,
    ALL of your shares will appear.

    if they do not, then the firewall or file/print sharing is not correctly setup,
    ASSUMING your networking is correct
  13. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Sorry, but that path does not appear on W98. After map network drive I get a sub-window headed Map Network Drive. In this are 2 boxes: Drive and Path. Drive has a drop-down list of letters assignable to drives. There is no option to Browse.

    Re firewall, I normally have Windows' disabled and rely on ZA. Earlier I discovered that the freeware version only allows ICS if set to Medium instead of High protection. Having done this, I have full Internet access on W98, and I guess I should think about upgrading to the Pro version for full protection.
  14. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    hey this is progress; your network is now sane:) !

    now you need solve the sharing issues -- likely to be permissions on the XP
    share point.
  15. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Since your settings seem okay for ICS now, this isn't a concern. But in the future, you can follow these directions for 98 and these directions for XP.
  16. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Yes, half the problem now solved and many thanks for pointing me in the right direction.

    Now, how do I tackle the inability to access XP's files etc from W98, please???
  17. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    You did not mention trying to log into Windows 98 under the same name as your XP account. Have you done this?

    The process is:
    • Create a regular ol' shared folder in XP.
    • Log off from Windows 98
    • Log back into Windows 98. Type your XP account's user name at the login prompt and continue.
    • Access your computer as you usually do (Browse for it or type in \\name_of_computer in the address bar of Windows Explorer)
    • You should be prompted for a password. Type in the same password you use for the XP account your logging in as.
    • Your $IPC error should go away and it should let you in.

    If it does not, then you could have a problem with permissions. Before getting into that though, you should try deleting and recreating the share.

    Next, make certain your "Client for Microsoft Networks" service is installed on your 98 computer, as I'm pretty sure this could cause a simlar problem.

    If it is and you continue to have issues, you can boot into safe mode and a new tab called 'Security' will appear if you check your folder's properties. You can do some advanced editing here, just as you could in XP Professional. You can also use Start > Run > cmd.exe and type in calcs to edit permissions ('Access Control List') via command prompt without having to go to Safe Mode, although it will be more tedious.
  18. jobeard

    jobeard TS Ambassador Posts: 13,410   +315

    Simple File Sharing is performed by accessing the Guest Login, using that password, if any.
    The account can still be disabled for login, but the permissions are per the Guest account.

    To protect this kind of access;
    1. set guest to active
    2. assign a password
    3. then disable the account

    now a rouge user must still have the password even if they have access to the Lan.
  19. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Yes, I said in my opener that I log on to both machines with the exact same user name & password. I have 2 "dummy" shared folders on XP named "Shared Docs" & "Test". Deleting & recreating them makes no difference.

    I also have Guest enabled but without a password. And what's a "rouge user"?

    I confirmed that Client for MS Networks was installed on W98.

  20. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Oh, sorry about that. I didn't notice it for some reason. :)
    Opening the 'Security' tab on the folder(s) you are sharing under Windows XP will give you more details about your permissions and the power to edit those settings.
    Changing permissions will only be useful if you do it on the XP computer. For XP, cmd.exe (or just cmd) will bring up the command console. In Windows 98, I said the command console was command.exe... If remember correctly - it's actually command.com. Typing in just command should work though. You can avoid the cmd prompt all together though, by using the Security tab under Safe Mode instead.
  21. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Thanks for the clarification Rick. I just hope I'm not being too obtuse, but here's what I did:

    XP in Safe Mode. Checked all 3 shared items, e.g. Root of C Drive, plus the 2 dummies. Hit Sharing/Permissions, and in each case the only permitted userwere appears as "everyone". The sharing item only came up as XP's name. It was not possible in Safe Mode to add either the individual names who log on (as opposed to "Everyone"), or the workgroup name, or the name of W98.

    This suggests we may have hit on a clue but I don't know how to proceed next.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.