TechSpot

Another locke1.exe problem

By shortyjill
Oct 4, 2005
  1. Hi, I'm another one with the lock1.exe problem... I'll attach the HijackThis log I got but after I find out what I need to get rid of I'm not quite sure of how to get rid of it. I'm very new at this.
     

    Attached Files:

    • log.txt
      File size:
      9 KB
      Views:
      12
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Boot in Safe Mode, see how here.
    Switch System restore OFF, see how here.
    In Windows Explorer, turn on "show all files and folders, including hidden and system". See how here.

    Next, open Windows Task Manager by pressing CTRL+ALT+DELETE.
    Click the Processes tab, select the process (if there) and click End Process for:
    winampa.exe
    ViewMgr.exe
    WinFixer2005ScannerInstall[1].exe
    lock1.exe
    c4nn0t.exe
    Weather.exe
    KHost.exe
    LimeWire.exe

    Next, click on Start/Run and type in (followed by press Enter):
    regsvr32 /u C:\WINDOWS\system32\ssttt.dll
    regsvr32 /u C:\Program Files\AIM Toolbar\AIMBar.dll

    Next, click Start/Control Panel/Add/Remove Programs. If there, UNinstall anything to do with:
    C:\Program Files\AIM Toolbar\AIMBar.dll
    C:\Program Files\Viewpoint\Viewpoint Manager\ViewMgr.exe
    C:\Program Files\My Love\c4nn0t.exe ..(SECRETSERVICE)
    C:\Program Files\AWS\WeatherBug\Weather.exe
    C:\WINDOWS\kdx\KHost.exe ... (Kontiki Host)
    C:\Program Files\LimeWire\LimeWire 4.2.6\LimeWire.exe
    ==>> and you should UNinstall MSN Messenger as well, major source of infections! <<==

    Next, click Start/Run and type services.msc and click OK. Look for the service:
    lock1.exe
    Doubleclick it, click Stop if it's running, and change the Startup type to Disabled.

    Next, run a HJT scan and (if still there) place a tick-mark in the little square before:
    ...................................................................................................
    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar = http://channels.aimtoday.com/search/aimtoolbar.jsp
    R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant = http://channels.aimtoday.com/search/aimtoolbar.jsp
    O2 - BHO: MSEvents Object - {52B1DFC7-AAFC-4362-B103-868B0683C697} - C:\WINDOWS\system32\ssttt.dll
    O3 - Toolbar: AIM Search - {40D41A8B-D79B-43d7-99A7-9EE0F344C385} - C:\Program Files\AIM Toolbar\AIMBar.dll
    O4 - HKLM\..\Run: [WinampAgent] C:\Program Files\Winamp\winampa.exe
    O4 - HKLM\..\Run: [ViewMgr] C:\Program Files\Viewpoint\Viewpoint Manager\ViewMgr.exe
    O4 - HKLM\..\Run: [NI.UWFX5] "C:\Documents and Settings\Misty Rybak\Local Settings\Temporary Internet Files\Content.IE5\W5UFQZGT\WinFixer2005ScannerInstall[1].exe"
    O4 - HKLM\..\Run: [strtas] lock1.exe
    O4 - HKLM\..\Run: [SECRETSERVICE] C:\Program Files\My Love\c4nn0t.exe
    O4 - HKLM\..\RunServices: [strtas] lock1.exe
    O4 - HKCU\..\Run: [Weather] C:\Program Files\AWS\WeatherBug\Weather.exe 1
    O4 - HKCU\..\Run: [kdx] C:\WINDOWS\kdx\KHost.exe
    O4 - HKCU\..\Run: [strtas] lock1.exe
    O4 - Global Startup: LimeWire 4.2.6.lnk = C:\Program Files\LimeWire\LimeWire 4.2.6\LimeWire.exe
    O8 - Extra context menu item: &AIM Search - res://C:\Program Files\AIM Toolbar\AIMBar.dll/aimsearch.htm
    O9 - Extra button: WeatherBug - {AF6CABAB-61F9-4f12-A198-B7D41EF1CB52} - C:\PROGRA~1\AWS\WEATHE~1\Weather.exe (HKCU)
    O14 - IERESET.INF: START_PAGE_URL=http://ie.redirect.hp.com/svs/rdr?TYPE=3&tp=iehome&locale=EN_US&c=Q105&bd=pavilion&pf=laptop
    Fix ALL your O16 - DPF: entries
    O20 - Winlogon Notify: ssttt - C:\WINDOWS\system32\ssttt.dll
    ...................................................................................................
    Now click on the Fix Checked button in HJT. Exit HJT.

    When done, from between the above dotted lines, delete the highlighted bold files.
    When a \directory-name\ is bold, delete everything in it, including that directory itself.
    Delete all files and directories from: C:\Documents and Settings\[username]\Local Settings\Temp
    Repeat this for ALL [usernames].
    Rightclick IE on the desktop, select Properties, click on Delete Cookies, and Delete Files.
    Delete ALL files and directories from: C:\WINDOWS\Temp (except files dated from TODAY).
    XP only: Delete ALL files from C:\WINDOWS\Prefetch.
    Boot normal. When all OK, switch System Restore back on.

    Stop using IE, except for Windows-updates.
    Get Firefox instead!
     
  3. shortyjill

    shortyjill TS Rookie Topic Starter

    When I boot up my computer in Safe Mode, after it's done starting up I only get a black screen with "Safe Mode" written in each of the four corners. I don't have a Start button nor are any of the processes running that I need to end. Do I have to do something to get these to show up?
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I don't know what screen that is.
    If Safe Mode does not work, try it in normal mode.
    Disconnect your PC physically from the internet.
     
  5. Victor587

    Victor587 TS Rookie Posts: 47

    have you logged in yet? If so, go into task manager (ctrl, alt, and delete) and under the applications tab, click "start process" and type in "explorer.exe" and click ok

    that should make your icons show and your taskbar appear
     
  6. shortyjill

    shortyjill TS Rookie Topic Starter

    I got it off! Thank you so much! :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...