TechSpot

Apache 128kb limit problem

By Scythy
Jun 7, 2005
  1. I'm having a really odd problem with Apache. It seems any file I host, be it a powerpoint, word file, jpeg, mp3, ect. They all get cut off at 128kb during download. I absoultely cannot figure this out and I need some help. Any help is appreciated. Thanks.
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  3. Scythy

    Scythy TS Rookie Topic Starter Posts: 39

    Well, I didn't install any additional modules, and I've used apache before but this is the first occurance of the problem. Also I know I'm not using any perl :p
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you sure it is an Apache not a network issue? Can you "download" stuff via localhost normally? How about uploading things somewhere?
     
  6. Scythy

    Scythy TS Rookie Topic Starter Posts: 39

    Well, I know it isn't a network issue because I have no problem uploading things to my friends via messenger or whatever. It just has the problem when someone wants to view or download something from my server. (My PC is the server by the way)

    I've also tried to download the file from the server via local host and I get the same odd problem

    Example: Lets say I want to put this image on a message board:

    My server: Server down for re-install

    It shows the incomplete gif, which turns out to be exactly 128kb

    Imageshack.us: [​IMG]

    This is the complete gif after it has been uploaded to imageshack. Also proof it isn't a network problem :grinthumb:

    I'm really stumped with this, and any help is very appreciated. Thanks!
     
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    That guy has a voracious appetite!

    At least you know/confirmed it is a setting on YOUR PC.
    What about firewall-limitations, or your ISP has bandwidth-issues?


    LimitRequestBody directive
    Syntax: LimitRequestBody bytes
    Default: LimitRequestBody 0
    Context: server config, virtual host, directory, .htaccess
    Status: core
    Compatibility: LimitRequestBody is only available in Apache 1.3.2 and later.

    This directive specifies the number of bytes from 0 (meaning unlimited) to 2147483647 (2GB) that are allowed in a request body.

    The LimitRequestBody directive allows the user to set a limit on the allowed size of an HTTP request message body within the context in which the directive is given (server, per-directory, per-file or per-location). If the client request exceeds that limit, the server will return an error response instead of servicing the request. The size of a normal request message body will vary greatly depending on the nature of the resource and the methods allowed on that resource. CGI scripts typically use the message body for passing form information to the server. Implementations of the PUT method will require a value at least as large as any representation that the server wishes to accept for that resource.

    This directive gives the server administrator greater control over abnormal client request behavior, which may be useful for avoiding some forms of denial-of-service attacks.

    If, for example, you are permitting file upload to a particular location, and wich to limit the size of the uploaded file to 100K, you might use the following directive:

    LimitRequestBody 102400
     
  8. Scythy

    Scythy TS Rookie Topic Starter Posts: 39

    Aye, It's the host of "Iron Chef".

    I couldn't find any setting for LimitRequestBody, but I did notice that my apache is version 2.0.54, and "LimitRequestBody is only available in Apache 1.3.2 and later."

    Looks like it's time for an upgrade :) I'm going to install a newer version and see if I still have the problem. Thanks for pointing that out Guinness man :grinthumb
     
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you checked the Apache logs? Every GET is logged in the access log and all errors go to the error log.

    LimitRequestBody goes for client requests, not server responses.
     
  10. Jimb0

    Jimb0 TS Rookie

    Sorry for digging up an old thread but I got exactly the same problem, I did not have this problem a while ago then I re-installed Apache with Netserver and I got this problem, tried to re-install it back but without any luck.

    Using apache_2.0.55-win32-x86-no_ssl.msi btw.
    Scythy did you find any solution?
     
  11. jobeard

    jobeard TS Ambassador Posts: 9,351   +622

    I saved your GIF to my Apache/2.0.54 (Win32) on a laptop (it is 605k)
    and accessed it by URL and it loaded fine.

    I note that the conf/httpd.conf is void of 'LimitRequest*'
     
  12. Jimb0

    Jimb0 TS Rookie

    For some time ago I also used 2.0.54 and it worked just fine, then I re-installed it and I got this problem.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...