ASUS A7N8X-X mobo power switch problems

By mike18
Feb 27, 2005
Topic Status:
Not open for further replies.
  1. I recently bought an ASUS A7N8X-X mobo and installed it in my roommates computer. It was working fine the way i had it, but once in awhile when you would press the power switch button on the front the LED / power would go for 1/2 a second and stop, then you would push again and it would be fine. We then bought some new RAM for him. Once I installed it, I got a few beeps and no display. Im sure that wasnt good. It was (not sure brand name, but somewhat cheap $60) 512MB PC2100 DDR 266Mhz 184-pin 64x72. Now when i put my stick in there (crucial 512MB PC2700 DDR RAM) which was in it before the upgrade and working fine, when i press the power switch it always does the blink and power off. It is really frustrating and i cannot find the source of this problem. I messed with the wires that go to the mobo and everything looks correct according to the mobo manual. Also wondering if it may be the power supply? Its an Enermax 330W PS and he doesnt have much in the pc that would be taking power > 2 CD/DVD drives, 1 HDD, floppy, video card, sound card, thats it. Really aggravating would really appreciate some input!!!! thanks
  2. fishhookz

    fishhookz Newcomer, in training Posts: 177

    Before upgrading hardware, always default BIOS to auto and maybe uninstall old drivers. Check mem settings there.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.