Asus M2N-SLI Deluxe - Prior warning help

By plastik7
Jul 26, 2006
Topic Status:
Not open for further replies.
  1. Greetings everyone.

    This weekend I'm about to embark on building my new machine, and I would like to get some insight from you guys on problems I'm more than likely going to come across and what I should have ready and DL'd before i go into it.

    The configuration of my box to be built:
    (I have all the pieces already, just waiting till friday for my CPU to arrive)
    Mobo :: Asus M2N-SLI Deluxe
    CPU :: AMD Athlon 64 X2 4600+ Dual-Core
    HD :: SATA WD 250GB (two of these)
    CD/RW/DVD/RW :: Plextor PX-755SA (SATA)
    Video Card :: Asus GeForce 7600 GS 512mb
    RAM :: Samsung Dual Channel DDR2 533 PC2-4200 (four 1GB chips = 4GB)
    OS :: Windows XP Pro x64

    I do not have a floppy drive, would you advise me to buy one for this or will i be able to use my USB flash drive to update BIOs etc?

    I'm going to just use 1 of the HD's during install and once i get windows running then i was going to pop in the other SATA drive and 2 IDE drives that i pulled from my Win2k box.

    Basically, based on the problems you've encountered, could you give me some tips on what i may come across this weekend just so i can be ready for anything.

    much thanks in advance!
    plastik
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,565

    Is this your first time to put a system together?

    Your parts look good from what I can see. What PSU will you be using?

    If it is your first time, be sure you use the riser pins in your case when installing the motherboard. A mistake many people make is installing the motherboard directly into the case, shorting it out and often damaging some parts.

    The only other potential problem I see is finding all the 64bit drivers. Does Asus have them ready for you to download on their support pages? I'd download those and have them ready.

    Good luck!
  3. plastik7

    plastik7 Newcomer, in training Topic Starter

    Hey Don,

    Your the one who suggested to me a month ago to go AM2, so i got all my componants and now that AMD lowered the prices on their x2 chips i got a 4600 for less than the 3800 was at high price.

    Yeah i've built a few machines before this one, but I was just reading over some other peoples issues with winxp pro x64 and this mobo and RAM etc.

    I just wanted to see if anyone ran into any problems with a similar setup they wouldn't mind sharing resolutions for, just so i can think about it before i start to build.

    as for the x64 drivers, I have Dl'd the Nvidia drivers (graphic card) and the nvidia nforce raid drivers, and all the x64 drivers that asus has put on it's website.

    PSU, i'm using an Antec True Power 2.0 550watt

    I'll for sure make notes to any problems i encounter during build and fixes if any, for others to read over.

    thanks
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.