TechSpot

Asus P4S800D-X No picture!!!!

By Raffizzz
Oct 22, 2006
  1. Hey guys I recently installed Asus P4S800D-X, everything is connected, when I start the cpu, the green light on the mobo lights, hard drive and all fans start, but the screen is blank, I don't know what to do, or what the problem is.

    thanks, Raffi.
     
  2. N3051M

    N3051M TS Rookie Posts: 2,800

    Tutorial: NO POST / Power General troublshooting

    Main points:
    -Have you checked everything is seated properly?
    -is there enough power to run the video card?
    -electrical shorts?
    -any beeps?


    For the purposes of not making confusion, we'll refer CPU as the Central Processing Unit chip (eg the Intel/AMD) and Computer/PC for the actual machine as a whole.
     
  3. rr5678

    rr5678 TS Rookie Posts: 32

    Maybe it's the RAM. Do you have another stick of RAM? If so, did you try it and remove the other one?
     
  4. Raffizzz

    Raffizzz TS Rookie Topic Starter Posts: 33

    Thanks guys, I took out the PCI cards, and it worked, but NOW I'm stuck installing windows xp, it can't find my hard drive. I have a seagate 300g sata hard drive. ???? don't know what to do next, help..
     
  5. N3051M

    N3051M TS Rookie Posts: 2,800

    you will need to look for your SATA drivers.. they should be on the cd that came with your motherboard. Follow the instructions on how to use the drivers if it needs to be created on a floppy disk do so.

    Simply press F6 when you're loading up the windows CD when it says at the bottom "Press F6 to load third party SATA/RAID drivers"
     
  6. Raffizzz

    Raffizzz TS Rookie Topic Starter Posts: 33

    Thanks, I will try that.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.