ATI Diamond Stealth S60 Radeon 7000 64mb

By Bingo
Jan 18, 2007
  1. Hi ... new guy with what I'm sure is a simple and annoying question.

    Not a real gamer, but was always annoyed that I didn't have a video card to play some of the old games lying around the house (young son interested).

    Put in the above card and had a heck of a time ever since.

    Looks decent now, but two problems exist.

    1. The monitor updates in a lazy wave when I scroll down on a web site or email, and things like icons etc update slowly in a wave. Clearly wrong.
    2. Can't play games as the 3D isn't working. dxdiag says Direct3D functionality not available.

    The old card was onboard and didn't have any details in the BIOS peripherals.

    I noticed in Add/Remove Programs I have S3 3Display, S3 3Overlay etc, but they won't go away when I try to remove them and didn't go when I ran Driver Cleaner 3

    Any thoughts?

    Thanks in advance
  2. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    Are the drivers for the new card properly installed? The generic windows driver will run like hell even on never cards.
  3. Bingo

    Bingo TS Rookie Topic Starter

    Yes ... from the software provided.

    Tried drivers from the net and ended up leaving my BenQ monitor "Out of Range". Stripped them out and reinstalled them from the CD in SAFE MODE and at least now I can get in cleanly.

    Just the nasty and slow wave refresh and the 3D card not working.
  4. dopefisher

    dopefisher TS Rookie Posts: 444

    does your bios have an option to select agp or pci or onboard as the primary video card?

    also, if you are getting the lazy scrolling thing, your ati card is NOT installed. (obviouosly lol)

    another thing, go into device manager in your system control panel and try diasbling the onbaord viideo as well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...