ati help

By ali666
Jul 28, 2005
  1. --------------------------------------------------------------------------------

    Hi I'm new here

    Hopefully somebody can help me I've got a Radeon 9800se but as soon as I install the latest drivers I get the dreaded blue screen but the weird thing is as soon as uninstall the drivers the computer works fine I've tried everything I've updated the bios and checked all the system and everytihing is working fine apart from the card
    My brother has had a look and he can't whats wrong with it

    Please help coz I would love to play some games
  2. PanicX

    PanicX TechSpot Ambassador Posts: 669

    You can always try a previous version of the drivers, or the drivers that came on the CD with your card.
  3. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Just in case, when you installed the latest driver, did you uninstall the old one first?
  4. Abraxas

    Abraxas TS Rookie Posts: 157

    The latest stable drivers are not always the best. And beta drivers are yet another thing. Don't upgrade unless you experience problems or until you know that the new drivers will give you advantages you didn't have before.
  5. ali666

    ali666 TS Rookie Topic Starter

    i've tried all them and none have them worked

    I even reinstalled windows and then installed drivers but as soon as I installed them it gave me the error screen
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...