TechSpot

ATI Radeon Performance Problem!

By jhmisa
Dec 27, 2004
  1. Hello All,

    I need your help. I'm having problems with FARCRY performance. I am sure that my machine should perform so much better so I need any suggestions possible. Before anything else I would like to say what I tried first so I would not waste anyone's effort. I used to have an NVidia 5600 FX card when I installed Farcry, I had huge lags when starting gunfights and the graphics looked crappy, I also had a static sound. so going to other forums I found out that the FX series is a problematic card, thus I decided to buy a new card ATI Radeon 9800 Pro 128 MB, and I bought a PCI Creative Sound Blaster to replace my on board card. It solved the sound problem but am still having lags when starting at gunfights. I have to set everything to medium in order to make the game playable but even in those crappy settings, I still get lags.

    Problem Summary
    Performance problem with FARCRY - Running more than 80 frames per second without gunfights and when gunfight starts, I get (lag)stuttering and delay before I shoot the first bullet.

    Basically I've done the following...

    • Updated BIOS
      Installed Hyperion Drivers for VIA type motherboards
      Reinstalled Windows XP SP1
      Using latest Catalyst drivers.
      installed FarCry patch 1.3
      Disabled Fast Write
      Changed from 8x AGP to 4x AGP

    I think it may be a motherboard problem or a PSU problem but I don't have enough proof to suggest that one is the culprit. The funny thing is that when I used 3d Mark I got an acceptable score of 5435. I gave my brother my old 5600FX card and he get's 3500 score but he can play Far Cry in High Settings. It's just pretty frustrating that I have far more superior computer to his but I can't even run mine in Medium settings. Please I need your help.


    My System Spec are the Following
    AMD 2600XP
    GIGABYTE GA-7VT600 1394 Motherboard
    ATI Radeon 9800 Pro 128 MB.
    512 MB RAM
    80 GB HD
    300W PSU
     
  2. peacefull76

    peacefull76 TS Rookie Posts: 19

    okay i was getting the same problems with a pny geforce 6800 gt 256mb so i dont think the card was my problem so i checked everything i could and found out that my IDE cable was only a 40 conductor one wich forced me to go at CD speed wich is 33 mb/sec if im not mistaken. Your HD should be able to get bandwith as high as 133 mb/sec or more if it's SATA wich in that case my fix doesnt apply to you :p well my point is when i corrected this, the stutterings and slow downs almost disapeared.

    Another thing im thinking of, is get yourself another 512mb ! :p

    well try to check for the cable in your bios wether its a 40 conector cable or an 80 one.

    try to set your DMA settings in your bios to 5 or 6 wich are the equivalent of 100 mb/sec and 133 mb/sec

    Again if some tech sees my reply and find mistakes tell me ! :p im not some computer pro but lets just say i've grown with pc in my surrounding

    P.S. sry for my bad english, longue vie aux canadiens !! ! :D
     
  3. peacefull76

    peacefull76 TS Rookie Posts: 19

    BTW please let me know if this helped you out ! :) :bounce:
     
  4. Blakhart

    Blakhart TS Rookie Posts: 510

    Well,first thing I would do is set the desktop to 16bit color, and then go thru the game settings and change them to support 16bit color and textures. Try the game at 16bit, there will be few places where you will be able to tell the diff between it and 32bit. It should give you a definite performance increase.
     
  5. olefarte

    olefarte TechSpot Ambassador Posts: 1,427

    I also have 512 MB of ram, and I had this very same problem, and tried everything, including game tweaks. The last thing I decided to look at was my virtual memory. I increased it and it solved the problem. Instead of letting Windows manage it, use custom, and try setting your minimum and maximum the same. I had mine set at 1536, which I really thought was way more than enough, reset it to 2048, and Far Cry runs smooth as butter now. Some may say this is to much, but it sure worked for me.

    At any rate, it won't hurt to try, if it doesn't do any good, you can always set it back to what it was, no harm done.

    Oh, also make sure you have defragged, that might help also. If you haven't done it in a while, you probably need to anyway.

    Hope this helps. Let us know if it does. Or not.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.