Audio device not working

By DrakeLode
Dec 29, 2009
  1. So I had some problems with computer hanging, my old harddisk couldnt move my mouse and keyboard. Yada yada yada, all that settled, I got a new harddisk, better cooler.

    Now a new problem arises, I never had a sound device in the first place, just got one today, seems like a waste for the SupremeFX X-Fi that comes with the Asus Rampage II Extreme motherboard to not use it.

    Problem: The Razer Moray+ that I got doesnt work, there is a sound device, "ATI HD Audio rear output", probably the sound card, still doesnt work, did everything on troubleshoot, check plugs, enabled everything, nay, nothing.

    Anyone who got an Asus Rampage II Extreme and uses the soundcard should know there isnt a driver CD for the sound card, I installed every possible driver, still nothing. Using Windows XP SP3, anyone help please? Everything that you can guide me on is appreciated. ): I am sick and tired of all the problems from my computer already, month old project, my first DIY rig ): Everyone functions well, just one sound device...
  2. shanuanil1458

    shanuanil1458 TS Rookie

    audio cevice

    please do repair my audio device
    because it is not working
    an error message coming
    there is no playable audio device
    ttank you
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...