Averatec keyboard run amok

By rjsteve
Aug 10, 2005
Topic Status:
Not open for further replies.
  1. I have an Averatec 3150 laptop and the keyboard is going crazy. Page up and page down no longer work; sometimes several letters of the alphabet don't work; sometimes the delete key gets stuck and deletes everything it can. I tried uninstalling the driver and re-installing it. I tried attaching an external (USB) keyboard, which solves the problem somewhat. However, the original keyboard remains active also and so when the delete key decides to do its thing -- there's nothing I can do but reboot. Is there any way to completely disable the built-in keyboard? Any suggetions?
  2. zephead

    zephead TechSpot Paladin Posts: 2,483

    unless you feel like taking a blade to that keyboard, i suggest taking it in for service, so a tech can fix it or disable it.
  3. Robby

    Robby Newcomer, in training

    Any Success ?

    I am having major problem with my laptop's keyboard.
    If I could disable it when XP is running, I would be ok.

    Did you have any success ?

    Rob
  4. rjsteve

    rjsteve Newcomer, in training Topic Starter

    I still use an external keyboard, but after following the procedure below the keyboard stopped acting crazy.

    "Right click on the My Computer desktop icon, then go to properties. Locate and click on the Hardware tab then click on Device Manager. In device manager you can disable the internal keyboard and have only your external keyboard enabled."
  5. Robby

    Robby Newcomer, in training

    I appreciate the response.
    I have just been trying to disable the internal keyboard with no success.
    IT WON'T DISABLE.
    In Device mgr, there is a right click disable option on some of the hardware, but not for the PS2 keyboard.
    There is no separate entry for the Internal keyboard, and I have seen some suggestion on the web, that the Internal keyboard is connected to the PS2 plug(socket).
    I have tried uninstalling the driver, and it just get's reconnected, when Windows boots. (Plug & Play).
    I tried setting Plug & play to Manual, and it still 'finds the new hardware', and installs drivers.
    If I try disabling Plug & play, it is not healthy. EG Device Mgr can't display anything.
    I had a look in the BIOS, to see if it allowed disabling of the PS2 keyboard. It didn't.
    I realize that that would have been quite dangerous, but I was getting desperate.

    How did you disable it ?
    Was it available as a Right Click option ?

    Thanks Rob
  6. rjsteve

    rjsteve Newcomer, in training Topic Starter

    It seems like right clicking was an option. Actually, I'm on the road right now and traveling with a different computer, so I don't remember. What brand is your laptop?
  7. Robby

    Robby Newcomer, in training

    It's a HP Omnibook XE4100 F4649H 'KC' model

    Thanks, Rob
  8. zephead

    zephead TechSpot Paladin Posts: 2,483

    perhaps the bios setup on the lappy has such an option
  9. Robby

    Robby Newcomer, in training

    Thanks, I had already tried that.
    There is only an option to change the PS2 Mouse between 'Both' or 'Auto'
    One of those disables the laptop pointing device, if there is an external mouse connected to the PS2 socket.

    Unfortunately there is no similar option for the keyboard.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.