back pannel doesnt work

By musicman856
Mar 1, 2006
Topic Status:
Not open for further replies.
  1. the whole back panel doesnt work. No video, audio, mouse keyboard, usb, and networking... Tried installing second hard drive. if anyone could help me that would be great.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Sounds like the Mobo is dead, do any fans come on in the PSU,

    Check all is correctly seated, CPU, Memory, Add on Cards etc remove and replace, if the PSU kicks in and nothing works then the board is definately dead.
  3. musicman856

    musicman856 Newcomer, in training Topic Starter

    Fans come on, cd drives work, green light on mobo stays on and all the cards are properly installed.
  4. musicman856

    musicman856 Newcomer, in training Topic Starter

    allright well I got most of it working but i still do not have usb support.
  5. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    It really sounds like you haven't got all of the Chipset drivers,etc. and software installed . Make sure you do some reading at the Mb website for all of these items and look for updates from the versions you have , that may relate to your box.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.