Bad color with new apollo Geforce FX card

By granite
Feb 18, 2006
  1. Hey everyone.
    I just got a new card to replace the built in video for my e-machines
    I am running XP, and the new card is a 128mb DDR Geforce FX, nvidia card.

    While on built in video, my emachines showed windows media files (movie clips) just fine, using windows media player 10.
    With the new card, the color is all wrong. looks mostly black and white and green.
    with Quicktime the color looks right. But I would rather use Media player.

    Any ideas?

    thanks in advance
  2. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    You didn't say whether or not you installed the latest driver for your card.
  3. granite

    granite TS Rookie Topic Starter

    i installed the drivers that came with it. couldn't find the latest driver for it though
  4. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    I think there was a series of nVidia drivers that had a major problem with video overlay, if the card and drivers are from 12-18 months ago then they are probably the problem. Get the newer drivers here .
  5. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Just for you info, you can also get the latest ATI or Nvidia drivers by clicking the "Drivers" link at the top of this very page. Convenient, eh?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...