TechSpot

bad keyboard problems..

By sephyvaline
Jan 5, 2007
  1. firstly, excuse my lack of punctuation or capitalization in this thread. my keyboar is acting very very odd. i've rebooted, and tried other keyboards first, so its some odd setting on my computer somwhere. right now when i hit shift, ctrl, alt, or some other special use keys, it imputs multiple commands, ctrl key imputs ctrl left, alt and shift. caps lock imputs tilde and caps lock, num lock opens up the start menu. f9 opens up the task manager and imputs the functions for escape and the tilde key. any help/ideas would be greatly appreciated.
     
  2. tomrca

    tomrca TS Rookie Posts: 1,000

    go to, control panel/date, time, language and regional settings/regional and language options. from there you can reset your keyboard input etc
     
  3. sephyvaline

    sephyvaline TS Rookie Topic Starter

    languages were all set to eng
     
  4. tomrca

    tomrca TS Rookie Posts: 1,000

    which english. us or uk
     
  5. sephyvaline

    sephyvaline TS Rookie Topic Starter

    Okay, got to a new computer just now, ssorry for having to be so cryptic. Language was set to english(US), and advanced language services were off. Nothing ~looked~ out of the ordinary. Didn't see a reset to defaults button in there anywhere though.

    *Edit. Also, some times when i hit a letter key (such as G) the letter will come up followed by a number or two. I've also checked filter and sticky keys to make sure they're not on.
     
  6. tomrca

    tomrca TS Rookie Posts: 1,000

    all i can suggest at this moment is to keep working at the settings. bet its annoying for you?i will look to see if i can find more info on this problem
     
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Computer keyboards are cheap. Replace it and see if the problems go away. If it is a laptop keyboard they are not so cheap to replace...
     
  8. sephyvaline

    sephyvaline TS Rookie Topic Starter

    tried my wife's keyboard, no luck. Also i was thinking to myself it's been a while since i've reformatted, so i'll just do that, but i went to change my boot order, and even pre-windows loading the delete key doesn't work. I'm figuring now it's some problem with my mobo.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...