TechSpot

Belkin54g router - disconnected all the time!

By Zeth
Apr 5, 2008
  1. Hi!
    I'm using a belkin54g router through cables and not wireless but this is what happens...
    It works fine for about 20 seconds and then it gets disconnected for like 3 seconds then it continues for 20 secs and so on...So everytime I like visit Youtube, the film only loads for like 20 seconds and then stops loading, the internet comes back but the film is stuck. I'll have to refresh and do it again with the same result. Same thing happens when I play online games and stuff like that. I can't even download anything because the download gets stuck on like 2% or what ever and then it doesn't continue to download. :(

    Anyways..
    I'm using Windows Vista if that has got anything to do with anything.
    I'm pretty new to routers so be nice and tell me step by step or I'll be lost in the fire :eek:

    ~Zeth
     
  2. rf6647

    rf6647 TS Maniac Posts: 829

    Welcome to TS. The moderator will probably move this topic to a more appropriate forum.

    Connect this computer directly to the cable box or adsl modem. Use another LAN cable. The events viewer may have useful info if the NIC is having hardware trouble with the connection. Does this improve the connection?

    If the problem is specific to YouTube, then browser & internet security settings may be causing this behavior.

    The router and the modem box maintain log files. It is entirely possible that local conditions from the service provider are causing this problem. "Guides & Solved Issues" give some basic info in this respect to use the web interface to view the log files.
     
  3. jobeard

    jobeard TS Ambassador Posts: 9,348   +622

    the first thing we do is to update the router firmware :) google for your make/model number
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...