Black screen after plugging in XFX 8800GT

By mistertiki
Aug 7, 2010
Post New Reply
  1. As mentioned in the title, I'm receiving a black screen after plugging in my XFX 8800GT card.
    - The monitor's working because I can use it normally with integrated gfx.
    - my current specs are:
    CPU: Intel(R) Pentium(R) Dual CPU E2180 @ 2.00GHz
    MB: BIOSTAR P4M90-7A
    RAM: 2GB DDR2
    PSU: CoolerMaster GX650W, 44A on a single 12V rail
    I've taken the card back for testing at the XFX support counter before and it was shown to be working then. Could it be a hardware limitation of some sort I'm running into?
    I have previously using Driver Cleaner Pro to clean nVidia, nVidia WDM and S3 drivers from my desktop.

    Anyone have any ideas? Do I need to provide any other information?

    Thanks and Regards
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Start from scratch and do a complete re-install.
    Otherwise don't mess with it too much, as you may have to send it back for a replacement, and you do not want to make any changes that void the warranty.
    I would test it in another computer if you have the opportunity.
  3. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    It isn't clear to me from your post but did you plug in the card's external PCI-E power connector to the PSU?
  4. mistertiki

    mistertiki TS Rookie Topic Starter

    mailpup: Yep, I did plug in the 6-pin power connector at the tail end of the card.
    raybay: Sorry but what do you mean by complete re-install? Pulling all the plugs off the mobo and sticking them back in?
  5. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    Ensure that your Primary Display Adapter in BIOS is set to PCI Express.
  6. mistertiki

    mistertiki TS Rookie Topic Starter

    I'm using a Phoenix Bios 6.00PG. It says "Init Display First - PCIEx" under the PnP/PCI configuration section. Not sure if that's the same thing because I can't seem to find a "Primary Display Adapter" heading under any section.

    There's a "PnP OS" option that's disabled. Should I enable it?
  7. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    Enabling PnP OS is not required. Everything else seems ok.

    Do as raybay suggested. Take apart everything and re-assemble.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...