Blank screen, please help me with a decision

By Valten
Nov 22, 2006
  1. Hi all,

    In the past I was having problems with my pc just crashing and eventually it doesn't turn on. The motherboard light is on, fans work, I can hear the hard drive working but there are no beeps. I just bought a new cpu and for a while it turned on then it would crash as before and now it doesn't turn on again. My suspicion is that it's either the motherboard or psu but with the graphics card fan, cpu fan, motherboard light are all still on so I doubt it's that. I am going to order a new motherboard or psu can anyone suggest which I should do or alternatives? Thanks

    My pc:

    Intel Pentium 4 Northwood 2.8 GHz (478 socket)
    1Gb ram
    360 W psu
    NVidia FX 5200 graphics card
    motherboard is Asus P4P800
    2 Hard drives, 125 MB each (roughly)

    Also things like unplugging the HD, graphics card or RAM doesnt do anything, still no beep..etc.
    When I first got it to work after buying and installing the new cpu it was saying it wasnt detecting the cpu fan, but I dont know how that can be since it was running fine.
  2. brianj

    brianj TS Rookie

    Are you still getting th error message that the CPU fan is not detected, if so the mother board will shut down to protect the CPU' you need to make sure it is connected to the right pins on the motherboard
    Also that power supply is not sufficient for your computer get at least a 450-500watt Good brand do not get a generic as they don't last or put out the wattage advertised
  3. Valten

    Valten TS Rookie Topic Starter

    Yeah I remember the message that it wasn't detecting the cpu fan, I'll be getting a new power supply today but can you tell me how to get the computer to detect the fan or will a new power supply be enough?
  4. brianj

    brianj TS Rookie

    Check your motherboard manual for the correct location for the CPU fan header (IT is nearly always right along side of the CPU)
    If not it usually is printed on the board.
    If it's connected to the correct header make sure it is a firm fit and somehow not back the front.
  5. Valten

    Valten TS Rookie Topic Starter

    Okay thank you very much mate, I'll see what I can do and report back :).
  6. Valten

    Valten TS Rookie Topic Starter

    Okay I got the computer to work but now the screen goes blank after windows loading and safe mode doesnt work (stops after agp.sys). Both my ati 9800 and nvidia fx 5200 do this and I know I need the proper display drivers but without safe mode working I can't do it, anyone know how I can get around this using BIOS, making safe mode work or something?

    Also I put plug and play to 'Yes'
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...