TechSpot

Blank Screen?

By pnguye
Jul 13, 2007
  1. When i turn on the computer, the power source works fine and all fans are working but the screen is blank. At first i thought something was wrong with my video card so i tested it on a different computer and it work. I also thought something was unplug in my motherboard so i recheck quite a few times and everything that was necessary seem to be in the right position. Anyone know what could be the problem to my blank screen? My monitor is working also.
     
  2. murzyn1975

    murzyn1975 TS Rookie Posts: 25

    Maybe you accidentally disabled your video driver.
     
  3. pnguye

    pnguye TS Rookie Topic Starter

    disable as in the motherboard or the bios, because if it is the bios i cant do anything since it is a blank screen.
     
  4. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 527

    Make sure that your cpu fan is seated tightly. Try different memory or somehow check yours.
     
  5. pnguye

    pnguye TS Rookie Topic Starter

    i have did that a couple of times using a different company everytime. i also made sure my fan was tight as it possibly could. all same results.
     
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

  7. pnguye

    pnguye TS Rookie Topic Starter

    oh im sorry i didnt know there was a thread for this problem. my bad. thanks!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...