Blank screens with directx games

By prefixrex
Mar 14, 2007
  1. First of all hello to you im new,

    About 2 weeks ago i was happily playing counter-strike source went out for the night then came back two days later updated directx to the feb 07 release (from dec'06) ready in time for a lan party with my mates came to run counter-strike and all i got was a blank screen so i dried my other games and the same happened apart form UT, UT2004 & Serious Sam all of which use or can use OpenGl for rendering. so i used Happy DirectX Uninstall and reinstalled my Dec'06 dx9.0c but to no avail same blank screen.

    I've Checked my drivers and all are uptodate.
    Nvidia Forceware 93.71 (GeForce FX5700 Ultra AGP 8x)
    Motherboard drivers 05/03/2005,5.1.2600.2300 (Gigabyte K8U)

    I've even tried to goback to directx 9.0a/b/c earlyier c's oct'04,aug'06

    I've checked my GPU core temp and it hasn't exceeded 46 centigrade
    i've underclocked it as well (never overclocked)

    Help any suggestions


    >>System Specs<<
    CPU : AMD Sempron 2800/1.66ghz
    MBD : Gigabyte K8U
    RAM : 2GB Crucial ddr400
    VGA : Sparkle GeForce FX5700 Ultra (Forceware 93.71)
    SND : O/B RealTek 6ch
    DiX : Directx 9.0c (dec'06 again)
    OS : Windows XP Pro SP2 uptodate as of 14march 2007
  2. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    You have a ULi chipset, the same one as me. You're also describing the exact same problem I had when I switched from an ATI video card to an nVidia one.

    I thought the problem was with the AGP driver, so I uninstalled it and the problem was fixed, albeit without the AGP driver installed. The only problem was that I couldn't reinstall the driver; this looks to be a limitation with the ULi chipset (or me). The only solution was to reinstall Windows.

    So, maybe something has messed with the AGP driver. Just remember that you may not be able to reinstall it if you remove it to see if it's the same problem.
  3. prefixrex

    prefixrex TS Rookie Topic Starter

    I'll give the old reinstall a try and get back. it's just wierd how it just randomly happened not like i changed my hardware.

  4. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    Just remember, if you remove the AGP driver from the system, the only way to reinstall it is from the motherboard install disk.
  5. prefixrex

    prefixrex TS Rookie Topic Starter

    well after a removal of the agp drive and reinstall i was still having problems so i borrowed a friend ati radeon 9600pro but it was the same and my fx5700 ultra ran fine in his, so i'm off the build a new system,

    not sure wether to get the HIS x1650pro IceQ 256mb or the Inno3D i-Chill 7600GT any suggestion would be greatful i've got about £90 for a pci-express card.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...