TechSpot

Boots fine until extra RAM is installed

By rockypierre
Oct 25, 2003
Topic Status:
Not open for further replies.
  1. Blue Screen appeared:

    "unexpected kernel mode trap
    if this is the first time, reboot.

    if not, three steps:
    1. run a system diagnostic utility: memory check, faulty or mismatched memory; change video adapter.
    2. Disable/uninstall any newly installed hw or sw drivers. Use Safe Mode to remove or disable components
    3. Refer to Getting Started manual for more info on troubleshooting Stop Errors."

    OK. I pulled the extra RAM chips and booted from Win2K CD; CD entered a repair routine that re-copied winnt/system32 files, then re-booted to a "generic profile," since not enough resources were present to boot my normal profile. This boot is unable to access the LAN, or even to run Windows Explorer.

    I replaced the RAM chips, but now the boot routine recognizes the additional RAM, then freezes on the IBM Thinkpad logo. It will re-boot only if I remove the chips. I have also tried exchanging the chips with others--they work in all systems but this one.

    (ONE OTHER ITEM--Recovery Panel says: Following file is missing or corrupt: winnt\system32\ntoskrnl.exe)

    I cleaned the slots and chip contacts, got a good response, until:
    Alas...too good to be true.

    It re-booted twice, recognizing the 327mb of ram, then reverted to the same problem.

    No amount of further cleaning or substitution of chips (cleaning technique was Qtips in alcohol liberally drooled into the slots and scrubbing the chip contacts) has helped.

    My revised theory is that the cleaning may have temporarily restored some broken connection to the mobo that is now permanently shot.

    Eh?

    Specs
    Thinkpad 600x
    Model 26458PU
    Processor/Speed (MHz) Mobile Pentium III / 500
    Memory (std/max/type) (MB) 64/576 SDRAM (256K installed as 2x128 bars)
    Hard disk size 18GB
    CD-ROM speed 24Xmax-10Xmin
    Display 13.3" 1024x768 -- TFT - active matrix

    [Memory]
    Range Device Status
    0x0000-0x9FFFF System board OK
    0xC0000-0xCBFFF System board OK
    0xF0000-0xFFFFF System board OK
    0x100000-0x3FFFFFF System board OK
    0xFFFE0000-0xFFFFFFFF System board OK
    0xA0000-0xBFFFF PCI bus OK
    0xA0000-0xBFFFF Intel 82443BX Pentium(r) II Processor to AGP Controller OK
    0xA0000-0xBFFFF NeoMagic MagicGraph256ZX driver OK
    0xCC000-0xEFFFF PCI bus OK
    0x4000000-0xFFDFFFFF PCI bus OK
    0x70000000-0xDFFFFFFF Intel 82443BX Pentium(r) II Processor to AGP Controller OK
    0x70000000-0xDFFFFFFF NeoMagic MagicGraph256ZX driver OK
    0xE0000000-0xF7FFFFFF Intel 82443BX Pentium(r) II Processor to AGP Controller OK
    0xE0000000-0xF7FFFFFF NeoMagic MagicGraph256ZX driver OK
    0x40000000-0x43FFFFFF Intel 82443BX Pentium(r) II Processor to AGP Controller OK
    0x70400000-0x704FFFFF NeoMagic MagicGraph256ZX driver OK
    0x50102000-0x50102FFF Texas Instruments PCI-1450 CardBus Controller OK
    0xFFBFF000-0xFFBFFFFF Texas Instruments PCI-1450 CardBus Controller OK
    0xFFC00000-0xFFDFFFFF Texas Instruments PCI-1450 CardBus Controller OK
    0xDF000-0xDFFFF Texas Instruments PCI-1450 CardBus Controller OK
    0xFFDF0000-0xFFDFFFFF Dual-Band Wireless A+G Notebook Adapter OK
    0x50101000-0x50101FFF Texas Instruments PCI-1450 CardBus Controller OK
    0xFFBFE000-0xFFBFEFFF Texas Instruments PCI-1450 CardBus Controller OK
    0xFF800000-0xFF9FFFFF Texas Instruments PCI-1450 CardBus Controller OK
    0xDE000-0xDEFFF Texas Instruments PCI-1450 CardBus Controller OK
    0x50100000-0x50100FFF Crystal SoundFusion (tm) OK
    0x50000000-0x500FFFFF Crystal SoundFusion (tm) OK
  2. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    IBM Thinkpads are VERY picky about their memory. I know from experience.

    I had to try many, many different types of memories to find that one that works in my T21. The 600s are very picky as well. And many of the modules that did not work appeared to work, but would cause problems with the software or wouldn't load Windows.

    I happen to have 256mb of certified Thinkpad 600 memory, if you are looking for new memory. ;)
  3. rockypierre

    rockypierre TS Rookie Topic Starter

    OK, but:

    These are the same two chips that have worked fine in this machine for two years. I swapped them with identical sized chips from my wife's 600x; they work fine in hers, hers will not work in mine. I also had an old 64mb bar, which I cleaned and tried...same result.

    NOTE: The BIOS recognizes the added RAM, then stalls.
  4. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Then that is bizzare.

    Judging from your diagnosis, I imagine your initial assumption is correct - the laptop itself is probably damaged.

    The best thing you can do is keep fiddling with it. And remember that nothing is too small to look at it. Even something as unrelated and simple as AC power instead of battery power could make a difference.

    You may even want to take the thing apart as much as possible and piece it back together to see if the error varies or disappears.

    To clean RAM contacts, I usually use a pencil eraser tip. It works pretty well and keeps me from making any mistakes with liquids.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.