TechSpot

Brand New (bought Today) Speakers Are Not Responding!

By Ghu
Aug 3, 2007
  1. Hi, i just got some new speakers and when i plugged it in the power outlet and the computer the light goes on, but when i try something with sound it doesn't work! I went to the control panel and looked at the sound and audio devices, it said there was no device plugged in! I even tried my microphone but it still didn't find it!


    PLZ HELP!
    THX!
     
  2. nickc

    nickc TechSpot Paladin Posts: 923   +11

    to me it sounds like the drivers for you're sound device (sound card or on board) is lot loaded try to reinstall it.
     
  3. Ghu

    Ghu TS Rookie Topic Starter Posts: 18

    thx but.........how do u reinstall a driver?
     
  4. Ghu

    Ghu TS Rookie Topic Starter Posts: 18

    the stupid thing is the speakers didnt come with a cd or instructions!
     
  5. nickc

    nickc TechSpot Paladin Posts: 923   +11

    if the sound is onboard u have a cd that came with the motherboard or it is a sound card u have a cd that came with the sound card. no device will wrk without drivers other than speakers and they have be placed in the right slot on the card to operate.
     
  6. nickc

    nickc TechSpot Paladin Posts: 923   +11

    the speakers should not need drivers.
     
  7. Ghu

    Ghu TS Rookie Topic Starter Posts: 18

    ya.....about dat, i dont no where those cds are im only 13 lol. and u no da_head (Secerity and the Web sticky about norton) hes my bro and he knos more than me
     
  8. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    You can also download the drivers from the motherboard manufacturer's website.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...