brand new computer won't turn on

By PyRoSS
May 9, 2005
Topic Status:
Not open for further replies.
  1. A friend of my got a computer for xmas and it doesn't work so im trying to fix it. Its a brand new eMachine T2862 (i know its a emachine). The switch on the front glows blue and there is a green led on the mobo that turns on. No fans work, hard drive doesn't spin. The fan on the PS does spin either.
    Any info will help?
    Thanks alot.
    Nick
  2. teztina

    teztina Newcomer, in training Posts: 24

    did u look to see if anything looks short circuited or improperly sodered?
  3. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    Follow the small lead from the front powerswitch to the motherboard. It has probably Power written on it. Remove it from the mobo, and 'short' it with a small screwdriver (but don't short anything else!).
    If the PC comes on, you'll have to replace that front-switch.
    Check also that all the PCI- and AGP-cards are seated properly, as well as all the ram-modules. Remove the powercord from the mains before you check that.
    Also check all the cables between motherboard and any hard- or CD-drives.
  4. blkoai

    blkoai Newcomer, in training

    Isn't it still under warranty?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.