TechSpot

BSOD IRQL not less or equal & page fault

By MadHatter47
Sep 30, 2015
Post New Reply
  1. A while back I started getting PAGE FAULT IN A NON-PAGED AREA BSODs. I moved my page file to a second on-board HD and the issue stopped. In the last week or so I've started getting the occasional IRQL NOT LESS OR EQUAL BSODs, and I got another PAGE FAULT BSOD, too. Maybe it's just coincidence, but these errors have only occurred while playing a video game (the Long War b15f3 mod of XCOM Enemy Within on Steam). I've also had VERY frequent crashes of the game (not windows) while playing the tactical missions (maybe it matters that this is the most graphics intensive part of the game) -- and from what I can see on the game's forums, game crashes like those I'm experiencing at NOT normal. So I'm assuming it's not the game's fault directly, but rather indirectly through what it's asking the system to do.

    My computer is self-built, most parts are 4-5 years old.
    Mobo: Biostar TA790GX A3+
    Power: this
    CPU: AMD Phenom II X4 955
    RAM: 4 GB RAM, Corsair brand and I think DDR3
    Graphics card: Radeon HD 5800
    Sound card: having a brain fart and can't figure out what type it is and don't want to open the case with my kids around if I can avoid it...

    Recent .dmp files are attached. I would be grateful for any advice!

    PS Sorry if the thread prefix is inaccurate, wasn't sure what to pick!
     

    Attached Files:

  2. Ben Lawson

    Ben Lawson TS Rookie

    Try this

    1) Open Start, right-click My Computer, and then click Properties.

    2) Click the Advanced System settings tab.

    3) Under Performance, click Settings.

    4) Click the Advanced tab.

    5) Under Virtual Memory, click Change.

    6) Click No paging file. Click OK, ok, ok and make sure to apply.

    7) Restart your computer.

    8) Open Start, right-click My Computer, and then click Properties.

    9) Click the Advanced System settings tab.

    10) Under Performance, click Settings.

    11) Click the Advanced tab.

    12) Under Virtual Memory, click Change.

    13) Click System managed sized. Click OK, ok, ok and make sure to apply.

    14) Restart your computer.

    Let me know if this helps!
     
  3. MadHatter47

    MadHatter47 TS Rookie Topic Starter

    Getting rid of the system managed page file reduced the number of page fault BSODs I got in the first place, but I suppose since I'm here asking for help I should obey! So, I will try this after work today and report back.

    As a separate note, I opened my case last night and cleaned out a lot of dust and reseated my RAM sticks. Then I played the game for quite a while with only 1 crash. Is it possible that dust was the problem?
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,322   +621

    Absolutely.

    Gamers tend to like running without a pagefile - - as a systems engineer, I've always considered that to be risky especially when you may run many applications at the same time. With a pagefile==0, you will at sometime create BSODs, out of memory.
     
  5. MadHatter47

    MadHatter47 TS Rookie Topic Starter

    I hadn't got rid of the pagefile entirely, I had just moved it to the second onboard HD (which is otherwise only used for my backups). In any case, I set both drives to have no page file, restarted, and then set both to system managed size. In the few hours I managed to play the game over the weekend, no crashes! Between the pagefile and the dust, I think the problem is solved!
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,322   +621

    MS requires a pagefile on the boot disk - - go look for it
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...