TechSpot

BSOD when laptop runs on battery (OK on power outlet!!)

By katone
Apr 3, 2006
Topic Status:
Not open for further replies.
  1. hi all, and thanks for this forum :grinthumb .
    I m having the weirdest problem: my laptop gives me BSOD when it runs on battery power. When I plug it in to the power outlet, everything is fine.
    Last BSOD message was: PFN LIST CORRUPT, but I also had IRQL NOT lESS EQUAL before..
    I tried running on different memory stick configurations, but still get BSODs while running on batteries (again, everything is fine when laptop is plugged on the wall..).
    I m lost. why would the computer do BSOD only when it runs on batteries???
    The machine is an intel centrino 1.3ghz with 1.25gb of ram, runs on xp pro.
    should I post my minidump or is there some steps I could take first? thanks for the help!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    Hello and welcome to Techspot.

    It sounds like the battery needs replacing. It`s obviously not providing enough power.

    Regards Howard :wave: :wave:
  3. katone

    katone TS Rookie Topic Starter

    thanks!! :)

    I have two batteries (one of them being almost new), and the laptop gives error with both..
    could they both be defective?
  4. kirock

    kirock TS Rookie Posts: 1,598

    It is possible they are both bad, but I agree with Howard your most likely cause of the BSOD is low power. Are you running any extras on the LP? Like a second USB HDD or an upgrade video card or other USB devices?
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    I suppose that`s possible.

    Can you rma the new battery?

    Maybe contact your laptop makers and see if they know what the problem may be.

    Regards Howard :)
  6. katone

    katone TS Rookie Topic Starter

    it gave me the bsod yesterday, and nothing was USB'ed on it..
    I did a HD upgrade on the laptop, tho, almost same model HD with an extra 20gigs on it (old HD became corrupted), I m wondering if that could be it maybe.

    I ll try what Howard suggests also: contacting Acer.

    thanks again
  7. moonaction

    moonaction TS Rookie

    I am having this problem also. I disabled HT on the CPU and it doens't do it unless i plug something in. Did you find a solution for this? Was it the battery?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.