TechSpot

can a router be fed by a pc with dial-up modem?

By alidabiri
May 4, 2007
  1. hi,
    i have a wireless laptop and a desktop pc that i'm trying to connect to gether. i have successfully tried wired and wireless network (peer-to-peer/ad-hoc). the problem with the wireless adapter on both pc's is that it has to be set up everytime you turn on the machines. file & printer sharing and internet connection sharing worked on both cases.
    i am now trying to connect a router to the desktop using an ehternet cable to the wan port. (this will look like any dsl/cable modem feed to the router). and let the laptop catch the wireless network that the router brodcasts.
    can this be done?
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,521   +336

    just to be clear, you want
    Code:
    dial-up ---- systemA -wired-wirelessRouter ..... systemB
    
    SystemA needs ICS to be active so that systemB requests get routed thru
    to the dialed connection. The systemA wired-side will be forced (by MS)
    to have address 192.168.0.1, so your router WAN address needs to be something
    else, say 192.168.0.254. Allow the router to provide DHCP from 192.168.0.10
    and up.

    You would be happier if BOTH systems connected to the router which connected
    to your ISP. Can you get ADSL service?
     
  3. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Just a note.. A hub or a switch or a wireless access point instead of the router would work just as well with much less headaches and configuration issues.
     
  4. tipstir

    tipstir TS Ambassador Posts: 4,761   +97

    DSL uses the phone line and has to be connected to your ISP to get the DSL signal for it to work. I guess you're able to get on the internet. Is the router wired or wireless or both?

    Each Router has a WAN port that's where you connected your DSL modem WAN port to the Router WAN port. Router can be setup to call your DSL ISP provided it uses the your username and password to connect. But it a system that re-connects as with cable modem it's a direct connection.

    So back in your Router there should be a setting for how you want your connection to act like. Who makes the Router?
     
  5. alidabiri

    alidabiri TS Rookie Topic Starter Posts: 540

    thanks everybody. basically here's the scenario:
    dial-up ----> system-A ----> linksys-wireless-router ----> system-B
    i connect the cable from system A to router's wan port which is basically what the dsl modem does too. i tried this last night, but since the router has its own setup schpiel, it didn't detect a signal while being setup. and system A couldn't communicate with router because ip address wasn't set. my question is: if i can get somebody with dsl to set up the ip address (static - not dhcp) on the router, would it stay with it? then i can connect it to system A (via wan port) and connect system B via wireless.
    any suggestions?
     
  6. alidabiri

    alidabiri TS Rookie Topic Starter Posts: 540

    thanks joe,
    the problem is that i can't get dsl service, but i get decent dialup (48k - i know it's laughable). but in the middle of a farming community, what can you expect. but you pictured my system setup correctly. the desktop has ics setup and running, and shares the connection.
    i tried to set up the router, but it requires internet signal to be setup and imbed an ip on it. without putting an ip address on the router, it's a no go.
    any ideas? would this work? does the router know signal speed?
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,521   +336

    got it; you're stuck with dial-up.

    From systemA to the router, your signal will require ICS to be activated.
    See my original post :)
     
  8. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Do not use the router's WAN interface.

    If you set up ICS on machine A, then it will also act as a DHCP server, so you have to disable DHCP in the router. Also, set the router's LAN IP so that it matches the Windows ICS local network and doesn't conflict with anything.
     
  9. jobeard

    jobeard TS Ambassador Posts: 13,521   +336

    the ICS connection on systemA WILL BE FORCED by MS to be 192.168.0.1,
    so the set the router to 192.168.0.254. All systems connected to your router
    will 'auto config'.

    You should be advised that sharing a dial-up is a real drag on performance,
    so don't believe you can play games or run Torrents with this setup :(
     
  10. Devcon

    Devcon TS Rookie Posts: 26

    I did this the other day with a Netgear wireless router. Connect the host computer to the router using one of the regular ports, and not the WAN port. (I don't know if that makes a difference but that's how i did it)

    -Set the IP of the router to 192.168.0.254.
    -Disable DHCP Server functionality with the router, it should be acting as a Wireless Access Point
    -Run the Network Setup Wizard, and be sure to select the dialup connection for you internet connection.
    -It will do it's thing and the IP of the host computer should now be 192.168.0.1

    With the client computer, you can just set up the IP to be 192.168.0.2, Subnet, 255.255.255.0, Default Gateway: 192.168.0.1, Preferred DNS: 192.168.0.1

    You only need to reboot the host computer, and you are all good. An internet gateway should have popped up on the client computer.

    And I haven't noticed a performance drop. All is good...
     
  11. alidabiri

    alidabiri TS Rookie Topic Starter Posts: 540

    still problem with router

    i connected desktop to port 1 of the router. desktop has dialup and ics is enabled.
    laptop is wireless. it picks up the signal from the router. it can share files and printer. but i think it's doing this through desktops wireless adapter, not the router. but internet is not working. it has it's own ip address and sees the gateway being the router (192.168.1.1). i think as you mentioned above, by doing ICS, xp forces the desktop to have 192.168.0.1. so it doesn't match the router. if i'm understanding you right, i should make the router's address 192.168.0.254 so they can connect? right?
    the desktop should be connected to port 1-4 - not the wan (internet) port.
    my router is linksys wrt54g v 8.0 with latest firmware
    the laptop has a linksys pcmcia card wpc54g
    the desktop has a lan adapter and a wireless adapter
    should i disable the wireless adapter on the desktop and just leave the lan adapter enabled?
    thanks.
     
     
  12. Nodsu

    Nodsu TS Rookie Posts: 9,431

    You did not disable the DHCP server on the router or the laptop IP configuration is set up manually. Either disable DHCP in the router or set the laptop IP configuration to automatic.
     
  13. alidabiri

    alidabiri TS Rookie Topic Starter Posts: 540

    problem resolved

    thanks everybody,
    devcon, nodsu, here's the scoop. you all were right.
    1 - i connected the router's port 1 (not wan) to ethernet port of pc.
    2 - launched browser, and went to 192.168.1.1 (router's ip address).
    3 - disabled router's dhcp.
    4 - chaned static ip of the router to 192.168.0.254 (more about this later).
    5 - saved the new ip address for the router.
    6 - disabled the wireless adapter on the desktop (host).
    7 - when you have ICS connection sharing, xp forces an ip of 192.168.0.1
    8 - so all other devices that want to talk to this, must have proper ip's
    9 - pinged the router - worked ok.
    10 - on laptop, i enabled wireless adapter (linksys).
    11 - set ip address to automatic (dhcp) on laptop.
    12 - on laptop set gateway to 192.168.0.254 (router's ip address).
    13 - ran network setup wizard with file and printer sharing.
    14 - pinged the router, worked ok
    15 - typed a url on laptop - bingo. it worked file.
    i must admit this was a very enlightening experience. i had been working on getting this to work for over a week. finally it worked.
    linksys has it's own app for the laptop adapter. when it starts, it says it connected to access point, but internet was not found. but it works.
    thanks again for all your advice. i appreciate your help.
     
  14. Devcon

    Devcon TS Rookie Posts: 26

    Good work, good to hear it's working...

    12 - on laptop set gateway to 192.168.0.254 (router's ip address).

    That guy isn't right. The gateway is the host computer at 192.168.0.1. Do you have a gateway icon in Network Connections on the laptop? If you don't, I think that is the reason. If you do, well maybe that's why the router is bothering to look for internet connectivity.
     
  15. alidabiri

    alidabiri TS Rookie Topic Starter Posts: 540

    thanks devcon.
    the gateway on the laptop is set to 192.168.0.1 which is the ip of the desktop, not the router. the router is acting just like a switch. the desktop is connected to the router vial a lan cable to port 1 (not the internet port). desk top has ICS working and that's why xp is forcing it to have 192.168.0.1.
    what's a gateway icon? how do i get it on the systray? everything is working like a charm but the laptop's nic card software (linksys) connects in ad-hoc mode (peer-to-peer/computer-to-computer) with the desktop via router, which is fine with me, complains about not being able to find internet. so, thanks again.
     
  16. Devcon

    Devcon TS Rookie Posts: 26

    I have the same setup, and windows should have created a Gateway Icon in Network Connections on your laptop. This just allows you to connect or disconnect the dialup connection from your laptop, so you don't have to walk back and forth. I know dial ups can be finicky at times.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.