Can`t play Pogo games with Firefox.

By glammomj
Mar 3, 2007
  1. hello, I'm new to this site. I'm hoping that some one can help me with a problem I encountered after downloading mozilla firefox. I can no longer play my pogo games.

    My kids convinced me that Mozilla was the way to go because there are less problems than with internet explorer. But....if I can't play pogo...

    I appreciate the help that anyone is willing to give me. THANK YOU!!
  2. chamillitarysk8

    chamillitarysk8 TS Booster Posts: 128

    what do you mean pogo games
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Pogo games uses Java, so you will need to do the following.

    Open Firefox and go to and download and install the Java plugin.

    Regards Howard :wave: :wave:
  4. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    It should have asked you when you attempted to play a Pogo game that you needed Java to run it ;)
  5. glammomj

    glammomj TS Rookie Topic Starter

    thank you

    OK> it works now. thanks for all the information!!!!
    pogo games are found on the pogo site.

    i'm addicted to playing games on this site. i'm even corny enough to go after the badges for playing games.

    THANK YOU!!!!!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...