Cannot boot from dvd on toshiba satellite laptop

By Iggy
Oct 4, 2007
Topic Status:
Not open for further replies.
  1. When I enter the BIOS on startup to reconfigure the boot device order, there is no "+" next to cd/dvd romdrive like there is next to HDD. It boots from the HDD regardless of the order in the list it is. If I disable HDD as an option, it just loops saying it can't find a network/external drive.

    Just recently (3 months) I used the Ubuntu live disk to boot off my dvd drive, no issues. I tried installing it, but it locks up tight every few minutes. I have a bootable XP disk (Same version that was on it before) that I am trying to recover from, but no luck. Installing Ubuntu shouldn't have messed with whether
    my BIOS sees my dvd should it?

    If there is any more info you need, I'll try to supply it.

    I have been working on this for a while now, and I'm starting to pull out my hair.

    Any help would be greatly appreciated.

    Iggy
  2. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    With most Toshiba laptops, when you first power it up keep pressing the left and right arrow keys. It will eventually then allow you to select the CD Rom to boot from.

    Get the timing right ...
  3. Iggy

    Iggy Newcomer, in training Topic Starter

    Tried, thanx

    Thank you for your reply.

    I tried your suggestion, and nothing happened.

    I can already select a boot device by pressing F12 on start up, but my problem is that, even with a bootable cd in the drive, it skips the dvd-rom and boots off of HDD.

    Anyone have anything else I can try?
  4. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    you have to change the boot order in BIOS. I have a toshiba and the boot order CAN be changed. Normally you hold F2, or DEL or some other function key upon boot up to enter BIOS.
  5. Brigadoon

    Brigadoon Newcomer, in training

    Are you certain the CD/DVD drive is actually working as I've seen a few reports of Toshiba CD drive problems.
    Does it show ok in Device Manager?
  6. Iggy

    Iggy Newcomer, in training Topic Starter

    I know how to change the boot order. I did it when I installed Ubuntu the first time. My problem is that the DVD is no longer a valid boot device for some reason.

    To recap: Even with a bootable cd in my dvd drive, it will not boot from there. Not if I hit F12 to select a boot device, not if I go into the bios to reorder the boot order so that DVD is on top. The DVD works fine once Ubuntu is loaded. I can read any disk I put in there. It shows up in DevMan fine.

    I'm starting to freak out a little. I have a very expensive paperweight, not a laptop.

    Thank you all again for your suggestions.
  7. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    Reboot your PC and continually press the left and right arrow keys. That is the way you can select a boot option for most Toshiba laptops.
    When you restart the laptop, as soon as it powers off, contunially press the left and right arrow keys. When you see the Toshiba Red logo, underneath it there will be options to choose what you want to boot from.
    that's the only way I know of for Toshiba's to select boot order. BIOS selections do not matter.

    It's all about timing it right.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.