Cannot enter IP in W98 Network TCP/IP

By RealBlackStuff
Sep 10, 2005
  1. Friend of mine wants to hook his W98 PC up to a router, using fixed IP.
    But in Network/TCP-IP Properties, it wont let me enter any numbers in the IP and subnet-mask fields.
    I can click on 'Use this IP' or whatever it says, but the fields are blocked, the PC beeps when I try to enter anything. The fields are not greyed out.
    OS is Windows 98.
    Any suggestions?
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Hey Real ;
    Try a couple of things ;
    Disable WINS resolution
    Use Ipconfig/winipcfg and renew/all or reset there.
    Make sure the Hosts file is not blocked by clicking the Enable DNS tab in TCP/IP property sheet
    That's all I can think of right now.
    I'll do some checking.
    Just read a possibility.Confirm that the nic card is properly binded to TCP/IP in the properties for the Card
  3. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks len,
    I've done all that, no luck. The only reason for the network is to transfer personal files onto a new PC.
    The new one has SATA/USB but no IDE (crap new Dell),
    and the old one has IDE but no USB/CDRW (crap old Dell).
    It also had no NIC and runs W98, not even W98se!
    So I can't put the old HD in the new one or use USB-key or CD-R.
    Miserable pieces of s h i t e Dell!
    I'll have to use a third PC with both IDE and USB (ANY PC but crap Dell) to transfer.
  4. greenflash

    greenflash TS Rookie Posts: 100

    dude DELL has always crap computers.I also hate the computers that VESTEL provides in Turkiye.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Uhm.. Yes of course.. Dell makes special hardware that prevents Windows network configuration from working properly..

    With Windows 98 it is always a good idea to remove all networking stuff (delete all protocols etc, uninstall the NIC drivers) and reinstall them.
  6. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Been there, done that.
    Took the HD out and put it in another NORMAL PC. Transferred the files onto a USB key, then formatted the Dell HD.
    It now got W2K on it and runs halfway decent.
    I sold it already to an unsuspecting noob.
  7. jobeard

    jobeard TS Ambassador Posts: 9,153   +598

    this drove me crazy until a friend suggested the following;
    ..uninstall the driver for the device using the device manager and then reboot.
    The uninstall does not delete the driver from the HD and the reboot will perform
    the auto discovery. Now you get back the TCP/IP stack and the ability to
    set IPaddr,mask,gateway, et al.

    Win/98 is just peculiar!
  8. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Tried that also, but did not work, however, the problem was solved already.
    Thanks anyway.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...