TechSpot

Cannot run MPEG4Modifier

By moriarty
Aug 23, 2015
Post New Reply
  1. I want to change the aspect ratio of an AVI video. All online sources recommend MPEG4Modifier but whenever I try to run the MPEG4Modifier.exe program file all I get is "MPEG Modifier has encountered a problem and needs to close. We are sorry for the inconvenience." The latest version also offers to send an error report. OS is XP Pro.

    I have tried several versions of MPEG Modifier, including the command line version, always with the same result - and yes, I do have Microsoft .NET Framework installed.

    I am extremely confused about .NET Framework. Is the version critical? A system requirement for MPEG Modifier is .NET Framework 2.0. Add/Remove Programs says I have .NET Framework 2.0 SP2, and if I click 'support information' it says "Version: 2.2.30729". There is a .config file with the current MPEG Modifier that includes:

    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
    <supportedRuntime version="v2.0.50727" />

    In my WINDOWS\Microsoft NET\Framework\ are sub-folders v1.0.3705, v1.1.4322, v2.0.50727, AND v3.0 and v3.5 folders.

    I've downloaded what I think is .NET Framework 2.0 (not SP-anything). What happens if I just attempt to install this over what I have at present?
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,348   +622

    Hmm; think that v3.5, 4.0 and 4.5 are the current versions, suggesting your MPEG4Modifier.exe is 'old stuff'

    look for Handbrake and/or MovieMaker.
     
  3. moriarty

    moriarty TS Rookie Topic Starter Posts: 21

    The MPEG4Modifier program is downloaded as a .zip, and the files in it are dated 10th Jan 2015. It seems to be the latest version.

    Shouldn't a program for which .NET 2.0 is a "requirement" work with later versions, anyway? Quite likely this is a red-herring and the problem is nothing to do with NET Framework.

    The advantage of MPEG4Modifier is that it does not need to decode/re-encode the video.
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,348   +622

    One would think, but v4 does not supercede v3.5, so I think anything requiring v2.0 is broken by design.
    that's the date it was archived into the zip, but nothing to do with the dependencies of .Net
     
  5. moriarty

    moriarty TS Rookie Topic Starter Posts: 21

    You're right of course. I dug out an old laptop, and this machine didn't have NET Framework at all, so I installed NET 2.0 and MPEG4Modifier runs and works fine! The directory tree only goes as far as 'v2.0.50727', and the NET Framework files are dated 23rd Sept 2005.

    Many thanks for your help.
     
    Last edited: Aug 24, 2015

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...