TechSpot

Canon Powershot A75 not wanting to upload pics to computer

By gamergirl
Feb 15, 2007
  1. My Canon Powershot A75 camera has been able to upload from the usb cable for awhile now. All of a sudden the other day it stopped working. I can still take pictures and I am pretty sure (have not tried yet), but I think I can still get them off the memory card. Anywho, if anyone can help I would appreciate it. Thanks a bunch :p
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Try a different usb cable and see if that helps.

    Regards Howard :)
     
  3. gamergirl

    gamergirl TS Rookie Topic Starter

    Have...still nothing. ;/
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Is Windows recognising the device is connected? I.E does it show up in my computer? Also, I suggest you try getting the pics of the memory card, just to check.

    Regards Howard :)
     
  5. gamergirl

    gamergirl TS Rookie Topic Starter

    I run on a iMac..800MHz PowerPC G4 512MB SDRAM...I've uploaded to this computer before (hundreds of times) and back then it recognized it just fine. I even tried it on a MacMini and it still didn't come up. ;/
     
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    It`s starting to sound like a faulty usb port on the camera. I don`t know what else to suggest, other than taking it in for checking/repair.

    Regards Howard :)
     
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,704   +397

    You could pick yourself up one of those 3,000-n-1* multimedia card readers and just pull the card out of the camera and put it in there, saves battery life too.


    *May have been exaggerated a little.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...