Can't connect to internet on one pc

By tornadouk
Mar 13, 2006
Topic Status:
Not open for further replies.
  1. I have a sb4100 modem connected to a netgear wgt634. I have a desktop and a laptop connected to it.

    One morning I switched my desktop on and the internet wasn't working (it worked fine the previous night). I checked the internet on the laptop and that was fine. I logged on to the router via the laptop and the router could only see the laptop. I've tried replacing the ethernet cable and reinstalling the network card driver and still no joy.

    I've scanned for viruses with AVG, and microsoft anti spyware to find nothing. I've tried system restore and the internet doesn't work even in safe mode with networking. So I don't think I have a virus or worm.

    On my network settings in says i'm connected to a network at 100 mps, and on interent explorer it says internet on the bottom right, though none of my programs can connect, internet explorer, firefox, update programs, msn etc.

    My network card is one built in to the abit an8 fatility mobo. Any help would be appreciated.
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    did you try connecting right to the modem see if its the router issue
    switch ports with the laptop or another port
    reset the router?? and the modem modem first in sequance
    assuming your on static ?
    reload the nic drivers for MB or see if there is new drivers available
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.