TechSpot

Can't install SP3, even in safe mode

By Nolat
Jan 23, 2010
  1. I've googled the heck out of this thing, but I can't find any solutions. My registry keys appear to be in order, there's no malware present, I have enough space, and iexplore.exe is present.

    Here's hoping that you guys have an idea. Here's my latest log from svcpack.log:

    10.469: 2010/01/23 21:25:02.578 (local)
    10.469: d:\ba5f6c4d8e9928a9b94c17\i386\update\update.exe (version 6.3.13.0)
    10.656: Service Pack started with following command line:
    10.656: In Function GetReleaseSet, line 1211, RegOpenKeyEx failed with error 0x2
    10.656: In Function GetReleaseSet, line 1240, RegOpenKeyEx failed with error 0x2
    10.719: CreateUserInterface: DefineInstallCustomUI returned 0x0
    10.766: Return Value From OnACPower = 1
    10.766: OnACPower returned value( 0x1 ) which is Equal To 0x1
    10.766: Condition succeeded for section OnACPower.Section in Line 1 of PreRequisite
    10.766: SOFTWARE\Microsoft\Shared Computer Toolkit is not Present
    10.766: Condition succeeded for section SharedComputerTool.Section in Line 2 of PreRequisite
    10.766: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix\KB925877 is not Present
    10.766: First Condition in RDPMUI.Section Succeeded
    10.766: Condition succeeded for section RDPMUI.Section in Line 3 of PreRequisite
    10.766: SYSTEM\WPA\Fundamentals is not Present
    10.766: First Condition in Winflp.Section Succeeded
    10.766: Condition succeeded for section Winflp.Section in Line 4 of PreRequisite
    10.766: SYSTEM\WPA\WEPOS is not Present
    10.766: First Condition in WEPOS.Section Succeeded
    10.766: Condition succeeded for section WEPOS.Section in Line 5 of PreRequisite
    10.766: Ident is Not Present
    10.766: First Condition in MediaCenter.FreeStyleBlock.Section Succeeded
    10.766: Condition succeeded for section MediaCenter.FreeStyleBlock.Section in Line 6 of PreRequisite
    59.969: In Function TestVolatileFlag, line 11825, RegOpenKeyEx failed with error 0x2
    59.969: In Function TestVolatileFlag, line 11857, RegOpenKeyEx failed with error 0x2
    59.969: DoInstallation: CleanPFR failed: 0x2
    59.969: In Function GetReleaseSet, line 1211, RegOpenKeyEx failed with error 0x2
    59.969: In Function GetReleaseSet, line 1240, RegOpenKeyEx failed with error 0x2
    59.969: SetProductTypes: InfProductBuildType=BuildType.Sel
    59.969: SetAltOsLoaderPath: No section uses DirId 65701; done.
    60.141: IncludeDirectoryIdFromInfSection: No DirId found for: DontRemoveOnUninst.DirId
    60.156: SupplicantMode is Not Present
    60.156: Fist Condition in Dot3svc.CheckSupplicantMode.Enabled Failed
    60.156: Condition Check for Line 1 of Dot3svc.Automatic.ExtendedConditional returned FALSE
    60.156: SupplicantMode is Not Present
    60.156: First Condition in Dot3svc.CheckSupplicantMode.NotEnabled Succeeded
    60.156: Condition succeeded for section Dot3svc.CheckSupplicantMode.NotEnabled in Line 1 of Dot3svc.Manual.ExtendedConditional
    60.172: C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\ToGac.exe is Not Present
    60.172: Condition Check for Line 1 of ToGac.RunProcess.ExtendedConditional returned FALSE
    60.172: FileVersion of C:\WINDOWS\system32\ntoskrnl.exe is Greater or Equal To 5.1.2600.2180
    60.172: Condition Check for Line 1 of DEP.RunProcess.ExtendedConditional returned FALSE
    60.172: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ie7 is not Present
    60.172: Condition Check for Line 1 of IE7.AdditionalSettings.Registry.ExtendedConditional returned FALSE
    60.172: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ie8 is not Present
    60.172: Condition Check for Line 1 of IE8.AdditionalSettings.Registry.ExtendedConditional returned FALSE
    60.172: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.172: Condition Check for Line 1 of N.And.WMP.ExtendedConditional.Common returned FALSE
    60.172: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.172: First Condition in Non.KN.WMP.Condition.Section Succeeded
    60.172: C:\WINDOWS\system32\wmp.dll is Present
    60.203: FileVersion of C:\WINDOWS\system32\wmp.dll is Greater or Equal To 10.0.0.0
    60.203: Condition Check for Line 1 of WMP.ExtendedConditional.Common returned FALSE
    60.203: SYSTEM\WPA\Starter is not Present
    60.203: First Condition in Non.Starter.Check.Condition Succeeded
    60.203: Condition succeeded for section Non.Starter.Check.Condition in Line 1 of Non.Starter.ExtendedConditional.MSXML6
    60.203: Ident is Not Present
    60.203: Fist Condition in MediaCenter.Condition.Section Failed
    60.203: Condition Check for Line 1 of MediaCenter.ExtendedConditional returned FALSE
    60.203: Ident is Not Present
    60.203: Fist Condition in MediaCenter.Condition.Section Failed
    60.203: Condition Check for Line 1 of MediaCenter.CopyAlways.ExtendedConditional returned FALSE
    60.203: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.203: First Condition in Non.KN.WMP.Condition.Section Succeeded
    60.203: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.203: First Condition in Non.KN.WM.Condition.Section Succeeded
    60.203: Condition succeeded for section Non.KN.Condition.Section in Line 1 of Non.KN.Help.ExtendedConditional.Professional
    60.203: SOFTWARE\Microsoft\Windows NT\CurrentVersion\HotFix\KB886540 is not Present
    60.203: First Condition in Non.WMP.Restore.Condition.Section Succeeded
    60.203: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.203: Fist Condition in N.FileOp.Condition.Section Failed
    60.203: Condition Check for Line 1 of N.Help.ExtendedConditional.Professional returned FALSE
    60.203: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.203: Fist Condition in K.Condition.Section Failed
    60.203: Condition Check for Line 1 of K.ExtendedConditional.Professional returned FALSE
    60.203: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.203: Condition Check for Line 1 of N.Restore.Help.ExtendedConditional.Professional returned FALSE
    60.219: Exec KN.Condition.Section: Result SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures Key Not Found
    60.219: Fist Condition in KN.Condition.Section Failed
    60.219: Condition Check for Line 1 of KN.Help.ExtendedConditional.Professional returned FALSE
    60.219: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.219: Condition Check for Line 1 of N.And.WMP.ExtendedConditional.Professional returned FALSE
    60.219: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is not Present
    60.219: First Condition in Non.KN.WMP.Condition.Section Succeeded
    60.219: C:\WINDOWS\system32\wmp.dll is Present
    60.219: FileVersion of C:\WINDOWS\system32\wmp.dll is Greater or Equal To 10.0.0.0
    60.219: Condition Check for Line 1 of WMP.ExtendedConditional.Professional returned FALSE
    60.219: C:\Program Files\internet explorer\iexplore.exe is Present
    60.219: Unexpected Error While Executing Line 1 ( IE.AdditionalSettings.LessThan7.Condition.Section ) of IE.AdditionalSettings.ExtendedConditional.Professional
    60.219: ExConditionalEvaluateSection: Syntax error in 'Condition' key of section IE.AdditionalSettings.ExtendedConditional.Professional.
    60.219: DoInstallation: Error 0xf00c while evaluating extended conditional section [ProductInstall.ExtendedConditional.IP].
    64.219: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine value, error 0x2
    64.219: DoInstallation: Failed to unregistering spuninst.exe for recovery.
    64.219: The Service Pack 3 d:\ba5f6c4d8e9928a9b94c17\i386\update\update.inf file is not correct.
    110.297: Message displayed to the user: The Service Pack 3 d:\ba5f6c4d8e9928a9b94c17\i386\update\update.inf file is not correct.
    110.297: User Input: OK
    110.297: Update.exe extended error code = 0xf00c
    110.297: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    Thanks a lot! I'm out of ideas, and I really want to get SP3 to work.
     
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    There is excellent help on the Microsoft Service Pack site. Have you looked there?
     
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,425   +77

    It can be iexplore.exe missing, or a missing or incorrect version of windows media player. Found this...

    "It turns out that this was the problem - not the version itself, but the fact that Windows Media Player was corrupt. I tried to update it to version 11, I tried to go back to version 10, but none of those worked. I then uninstalled Windows Media Player, and then re-installed from the XP system CD and was then able to update to verison 11. After that, Service Pack 3 installed fine."

    That from someone who used the same CD with SP3 to update 11 identical PC's, all of which went smoothly except one. I see in your log that wmp.dll is "version 10 or more", so if that is a clue or not I have no idea unfortunately, but updating to version 11 will probably do no harm. You also have warnings or unexpected errors about IE7 additionalSettings, so again a re-install of IE7 might or might not help.

    Although you are running in safe mode, are you quite sure there is no anti-virus package running AT ALL, even in safe mode? There is a case for actually uninstalling all malware programs and reinstalling afterward.

    I assume you have read KB950717 http://support.microsoft.com/kb/950717

    Just to encourage you to persevere, SP3 is really needed now, because XP security updates will only be for SP3 from July 2010
    "The clock is ticking for Windows XP SP2, as contributing editor Susan Bradley explained in her Dec. 17, 2009, Patch Watch column (paid content). As of next July, Microsoft will provide security updates only for XP SP3. Carl Spencer highlights one precaution some XP users need to take before applying Service Pack 3:" Windows Secrets Newsletter • Issue 227 • 2010-01-14

    http://www.windowssecrets.com/2009/1...e-wary-of-IE-8
     
  4. Nolat

    Nolat TS Rookie Topic Starter

    Updated Windows Media Player to version 11 and tried again. Still getting the same "The Service Pack 3 d:\ba5f6c4d8e9928a9b94c17\i386\update\update.inf file is not correct." error.

    I also read KB950717 and tried all the fixes there before. That article doesn't seem to have any details about the above error message though.

    However, my computer is unable to install IE8, or IE7 for that matter. When I try to install either of those I get an "Internet Explorer Installation did not complete" error.

    I guess I'll try to figure out how to fix this problem, and maybe then I'll be able to install SP3.
     
  5. raybay

    raybay TS Evangelist Posts: 7,241   +9

    I would boot to your original disk and run it in R for Repair mode. That will remove the original install without damaging the rest of your install, then reinstall ... that will fix the problem... but you will then have to re-install about 140 windows updates all over again, and Windows Service Pack 3.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...